0
$\begingroup$

Rosanswers logo

Traceback (most recent call last): File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/init.py", line 307, in main p.start()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py", line 268, in start self._start_infrastructure()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py", line 217, in _start_infrastructure self._load_config()

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py", line 132, in _load_config roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/config.py", line 451, in load_config_default loader.load(f, config, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 746, in load self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 718, in _load_launch self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 662, in _recurse_load self._param_tag(tag, context, ros_config, verbose=verbose)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 95, in call return f(*args, **kwds)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 264, in _param_tag value = self.param_value(verbose, name, ptype, *vals)

File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/loader.py", line 489, in param_value p = subprocess.Popen(shlex.split(command), stdout=subprocess.PIPE)

File "/usr/lib/python2.7/subprocess.py", line 710, in init errread, errwrite)

File "/usr/lib/python2.7/subprocess.py", line 1327, in _execute_child raise child_exception

OSError: [Errno 13] Permission denied

I created a basic urdf model as mentioned in the tutorials and wrote a launch file to view the urdf in rviz When i try to launch file using roslauch i get this error

<launch>

Originally posted by Yogi_4 on ROS Answers with karma: 38 on 2017-06-20

Post score: 0


Original comments

Comment by Airuno2L on 2017-06-20:
Some context is needed for people to help. Please see the guidelines for asking a question here.

Comment by Yogi_4 on 2017-06-20:
I have updated my question.Thank you!

Comment by ufr3c_tjc on 2017-06-20:
Please also post the launch file (and format it with the 0101 button) and tell us which OS and version of ROS you have.

Comment by gvdhoorn on 2017-06-21:
@Yogi_4: I don't see an answer to your problem here, but you have closed the question. If you've solved it by yourself, please post an answer telling us what you did and accept that. If you haven't solved it, then I don't think you should close it as answered.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

@ufr3c_tjc I have deleted the package and created the same again.I have re-written the same launch file and it worked.


Originally posted by Yogi_4 with karma: 38 on 2017-06-21

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.