0
$\begingroup$

Rosanswers logo

Hello~ I'm new in ROS and am learning it by the tutorials.However,there were some errors when I followed the Tutorial: Using a URDF in Gazebo. Everthing is normal until I ran the the command:

roslaunch rrbot_gazebo rrbot_world.launch

image description

However, it seems I can start gazebo by command line. image description

I have tried sudo apt-get install --reinstall ros-indigo-gazebo-ros,but it didn't work.

This is all the files I have in /opt/ros/indigo/lib/gazebo_ros/.Is there anything wrong?

image description

Thanks a lot for your help!


Originally posted by Richardaria on ROS Answers with karma: 21 on 2017-05-31

Post score: 0


Original comments

Comment by jarvisschultz on 2017-05-31:
How did you install gazebo_ros -- from source or from apt-get? What does rospack find gazebo_ros return?

Comment by Richardaria on 2017-05-31:
It returns this: /opt/ros/indigo/share/gazebo_ros

Should I reinstall Gazebo?

Comment by jarvisschultz on 2017-05-31:
You could certainly try sudo apt-get install --reinstall ros-indigo-gazebo-ros although, that wouldn't explain what went wrong in the first place. Do you have the missing executables in /opt/ros/indigo/lib/gazebo_ros/ (that's where they should get installed)?

Comment by Richardaria on 2017-05-31:
I tried sudo apt-get install --reinstall ros-indigo-gazebo-ros .However,the same problem still exist. I have attached a screenshot of all the files I got in /opt/ros/indigo/lib/ga zebo_ros/. Is there any problem? Thanks for your help!

Comment by jarvisschultz on 2017-06-01:
If that works, then there is likely something wrong with your workspace. Try deleting the build/ and devel/ directories and then re-running catkin_make

Comment by jarvisschultz on 2017-06-01:
Also, as a side note, please stop posting images to show information that is fundamentally text (list files in a directory, error messages, terminal commands, etc.). Images are not searchable nor are they copy/paste-able. Please post this type of thing using the preformatted text button.

Comment by Richardaria on 2017-06-01:
It works just as you said.Thanks a lot. It seems that I have installed gazebo twice.I'm not very familiar with the editor of this website, learning and improving. Thanks for you advice.

Comment by jarvisschultz on 2017-06-02:
Is your original question resolved? Can you now run your rrobt launch file?

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

Do you maybe have an additional copy of gazebo_ros in your workspace? Try using rosrun to manually start one of the missing nodes: (i) start roscore (ii) source /opt/ros/indigo/setup.bash to use just the base install (deactivates your workspace) (iii) rosrun gazebo_ros gzserver


Originally posted by jarvisschultz with karma: 9031 on 2017-06-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

I solved this issue by these steps:

  1. delete build and devel folders.
  2. catkin_make.

Originally posted by lyz with karma: 11 on 2019-01-28

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

This worked for me:-

sudo chmod +x /file path*(gzserver)

sudo chmod +x /file path*(gzclient)

sudo chmod +x /file path*(spawn_model)

*means location where the files are present

for eg:/home/tom/project_ws/src/gazebo_ros/gazebo_ros/scripts/gzclient


Originally posted by harrynick with karma: 23 on 2020-01-31

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Jeremy_Liu on 2022-04-11:
This works for me, too. Thanks!

Comment by Hector P on 2023-01-19:
This works for me, too. Ty!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.