0
$\begingroup$

Rosanswers logo

I try to connect VLP-16 to indigo in four ways, but all failed and led to the same result (no data was printed through command "rostopic echo /velodyne_points" and "rostopic echo /velodyne_packets"):

First method, refer to tutorial about VLP-16 http://wiki.ros.org/velodyne/Tutorials/Getting%20Started%20with%20the%20Velodyne%20VLP16

1 Access the Gnome Menu (Super key), type "Networks Connections" then run it.

2 Select the connection's name and click on "edit".

3 Choose the IPV4 Settings tab and change the “Method” field to "Manual". Set as below, according to http://answers.ros.org/question/235992/why-routes-are-deleted-using-vlp16-and-rviz/ :

image description

Is the setting correct?

4 sudo ifconfig eth0 192.168.3.100

5 I don't what it means in tutorial: "Add a static route to the LIDAR's IP address. The IP address can be found on the CD case which was included with the LIDAR. sudo route add 192.168.XX.YY eth0", since I don't have a CD. What should XX and YY be? Or can I skip this step?

Second method:

1 sudo route add 192.168.1.201 eth0 (Without turning off wire and change the settings in "Network Connections")

Third method:

1 sudo ifconfig eth0 192.168.1.77 (Without turning off wire and change the settings in "Network Connections")

Fourth method:

  1. sudo ifconfig eth0 192.168.1.77

  2. sudo route add 192.168.1.201 eth0

After any of the methods,

I applied:

$ roscore

change to the correct workspace

$source devel/setup.bash

$ roslaunch velodyne_pointcloud VLP16-points.launch

Then, $ rostopic echo /velodyne_points

$ rostopic echo /velodyne_packets

no data was printed from any command above

Or

rosrun rviz rviz -f velodyne

After open the interface: image description "No tf data. Actual error: Fixed frame [velodyne] doesn't exist"

So, what's wrong with the connection to VLP 16? Can you provide me with a detailed and correct way to connect VLP 16 to indigo (Don't mention the tutorial. It is based on HDL-32E)?

Thanks for you all!


Originally posted by T318forever on ROS Answers with karma: 31 on 2017-05-09

Post score: 2

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I don't think your Velodyne is connected, can you access the Velodyne interface on a browser ? The default IP address is 192.168.1.201. Looking at your screenshots, you have the name of the connection wrong, the connection has to be eth0. Change that and everything should work. Also, you need to add a pointcloud2 topic in Rviz, then double click pointcloud2 and from the drop down of topics, select /velodyne_points. You should be able to see your pointcloud then.


Originally posted by fiorano10 with karma: 45 on 2017-10-03

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by summer on 2018-01-02:
How to access the Velodyne interface on a broswer? I have entered the IP address in the browser, it shows can not found, how to change? thank you.

Comment by fiorano10 on 2018-01-02:
Okay, what if you enter 192.168.1.77 in the browser? Although, the default VLP-16 IP address is 192.168.1.201. You should try this to see which devices are connected.

Comment by summer on 2018-01-02:
ok , I do that, however, it dosen't work. the screen also shows NOT FOUND. What should I do?

Comment by fiorano10 on 2018-01-02:
What is the IP address of the VLP-16? You should know that once you see a list of connected devices. And once you figure the IP address, just type in the terminal and the Velodyne interface will open.

Comment by summer on 2018-01-02:
I should enter 192.168.1.77 in browser or terminal?

$\endgroup$
0
$\begingroup$

Rosanswers logo

To solve the problem of the "fixed frame" you have to define the transformation first. Before opening rviz you have to use the tf package according to the instructions at http://wiki.ros.org/tf

tf is used to "maintains the relationship between coordinate frames in a tree structure buffered in time".

According to the instructions I am using the following command and it worked for me.

rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map velodyne 100

Originally posted by jmabreo with karma: 11 on 2017-08-27

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.