0
$\begingroup$

Rosanswers logo

Edited with new information

Hi all

I'm trying to calibrate an onboard Asus Xtion using turtlebot_arm_kinect_calibration from the official turtlebot_arm repo here https://github.com/turtlebot/turtlebot_arm. When I run calibrate.launch I'm getting a popup that doesn't show the video stream, it just shows white, and I'm unable to proceed with the prompts for calibrating using the arm (a PhantomX pincher).

I am able to get a video stream from the xtion when I do rosrun image_view image_view image:=/camera/rgb/image_raw.

The calibrate.launch file looks like the below - the issue seems to be that the remap isn't yielding a viable image stream from /calibrate_kinect_checkerboard/calibration_pattern_out

 <launch>    
  <node name="calibrate_kinect_checkerboard" pkg="turtlebot_arm_kinect_calibration" type="calibrate_kinect_checkerboard" output="screen">
    <param name="gripper_tip_x" value="-0.002" />
    <param name="gripper_tip_y" value="0.020" />
    <param name="gripper_tip_z" value="-0.0185" />
  </node>

  <node name="checkerboard_image_view" pkg="image_view" type="image_view">
    <remap from="image" to="/calibrate_kinect_checkerboard/calibration_pattern_out" />
    <param name="autosize" value="true" />
  </node>
</launch>

The calibrate_kinect_checkerboard node has 2 references to the camera stream as default (one to camera/rgb/camera_info and one to camera/rgb/image_mono - I can't view either of these manually using rosrun image_view image_view image:=..., and replacing them with the topic I can view (camera/rgb/image_raw) doesn't help either

Any ideas what I can do to get my camera stream detected?

Cheers

Will


Originally posted by wjvh on ROS Answers with karma: 58 on 2017-05-01

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Solved this by changing camera/rgb/image_mono to camera/rgb/image_raw in calibrate_kinect_checkerboard.cpp, running catkin_make again and running the calibration launchfile again

Note that the image_view box that pops up doesn't seem to show a live video stream but if you place the checkerboard in front of the camera it'll grab a still image and proceed with calibration


Originally posted by wjvh with karma: 58 on 2017-06-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.