0
$\begingroup$

Rosanswers logo

Hello everybody.

I have looked really long for a solution but i cant figure out what the problem is.

I am trying to install the ros driver package for the duo3d camera http://wiki.ros.org/duo3d-ros-driver on the Jetson tk1 board. But every time i try the catkin_make command i will get an error output with:

...catkin_ws/src/duo3d_driver/lib/libDUO.so: file not recognized: File format not recognized
collect2: error: ld returned 1 exit status
make[2]: *** [...catkin_ws/devel/lib/duo3d_driver/duo3d_driver] Error 1
make[1]: *** [duo3d_driver/CMakeFiles/duo3d_driver.dir/all] Error 2
make: *** [all] Error 2
Invoking "make -j1 -l1" failed

Maybe some of you could help me with this problem :-)


Originally posted by moody on ROS Answers with karma: 31 on 2017-04-07

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Ok. I Figured it out myself:

the Problem was due to the wrong SDK in the devel folder of my workspace. For some reason the Driver had downlaoded the SDK automatically for the amd64. So the solution was to replace the wrong SDK by the one needed by armhf.


Originally posted by moody with karma: 31 on 2017-04-13

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Flacedoo on 2017-07-13:
Could you please specify what you've done exactly? I am encountering the same problem, but on an ODROID XU4.

Comment by moody on 2017-08-02:
Sry for the really late reply: hope you figured it out yourself by now. Else: Downloaded the correct SDK from their website and replaced the one in my devel folder with the one for armhf.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.