0
$\begingroup$

Rosanswers logo

I currently have made my map using Hector Slam and saved the map as .yaml file and .pgm .

I have downloaded the Navigation stack as well using git source: https://github.com/ros-planning/navigation.git . Also ran catkin_make afterwards.

Now, I am trying to implement AMCL by placing my robot( irobot create 2) onto the map and do autonomous mapping.

I am getting an error when i run am amcl file... which says " MapServer could not open <.yaml> file." Please see attached for my code.

Screenshot from 2017-03-23 10-48-08.png

Update:

I was able to upload map onto RVIZ, and executed amcl with proper tf/ messages. However, when I move the robot towards a location, the PoseArray points do not move. Please recommend a suggestion. Here is the screen pic. Screenshot from 2017-03-23 14-55-11.png


Originally posted by Shilpan on ROS Answers with karma: 96 on 2017-03-21

Post score: 1


Original comments

Comment by Shilpan on 2017-03-22:
I ran the following commands simultaneously.. roslaunch hector_slam_launch tutorial.launch rosrun map_server map_server .yaml roslaunch amcl amcl_diff.launch

but received message "No laser scan rece

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

rosrun map_server map_server <file_name>.yaml rosrun rviz rviz --> Add Map->topic /map

Issue resolved. Added tf code messages in AMCL launch file to configure with my robot.

Please see for follow up Q. link text


Originally posted by Shilpan with karma: 96 on 2017-03-24

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.