Rosanswers logo

I get this error when running catkin_make for the rosserial_tutorials_ buttons_buttons.axf

/home/pops/Tiva/src/rosserial_tivac_tutorials/buttons/buttons.cpp:28:47: fatal error: rosserial_tivac_tutorials/Buttons.h: No such file or directory #include "rosserial_tivac_tutorials/Buttons.h"

I have had not difficulty with "chatter" and "chatter129". I believe I am missing some dependencies in my kinetic distro.

Included contents of my CMakeLists.txt

cmake_minimum_required(VERSION 2.8.3) project(rosserial_tivac_tutorials)

find_package(catkin REQUIRED COMPONENTS







find_package(catkin REQUIRED COMPONENTS message_generation rosserial_client rosserial_tivac std_msgs )

add_message_files( FILES Buttons.msg )




generate_messages( DEPENDENCIES std_msgs )

catkin_package( CATKIN_DEPENDS message_runtime std_msgs )

rosserial_generate_ros_lib( PACKAGE rosserial_tivac SCRIPT make_libraries_tiva )

Because we need to generate our custom messages before exporting our rosserial ros_lib

#add_dependencies(${PROJECT_NAME}_ros_lib ${${PROJECT_NAME}_EXPORTED_TARGETS})

Chatter tutorial

rosserial_configure_client( DIRECTORY chatter TOOLCHAIN_FILE ${ROSSERIAL_TIVAC_TOOLCHAIN} ) rosserial_add_client_target(chatter chatter.axf ALL) rosserial_add_client_target(chatter flash) rosserial_add_client_target(chatter size) rosserial_add_client_target(chatter dump)

Chatter tutorial for TivaC Connected

rosserial_configure_client( DIRECTORY chatter129 TOOLCHAIN_FILE ${ROSSERIAL_TIVAC_TOOLCHAIN} ) rosserial_add_client_target(chatter129 chatter129.axf ALL) rosserial_add_client_target(chatter129 flash) rosserial_add_client_target(chatter129 size) rosserial_add_client_target(chatter129 dump)

RGB LED tutorial




#) #rosserial_add_client_target(rgb_led rgb_led.axf ALL) #rosserial_add_client_target(rgb_led flash) #rosserial_add_client_target(rgb_led size)

RGB LED service tutorial




#) #rosserial_add_client_target(rgb_srv rgb_srv.axf ALL) #rosserial_add_client_target(rgb_srv flash) #rosserial_add_client_target(rgb_srv size)

Custom message - Button publisher

rosserial_configure_client( DIRECTORY buttons TOOLCHAIN_FILE ${ROSSERIAL_TIVAC_TOOLCHAIN} ) rosserial_add_client_target(buttons buttons.axf ALL) rosserial_add_client_target(buttons flash) rosserial_add_client_target(buttons size)

How to get a parameter from ROS master


DIRECTORY getparam


#) #rosserial_add_client_target(getparam getparam.axf ALL) #rosserial_add_client_target(getparam flash) #rosserial_add_client_target(getparam size)

Time and TF example




#) #rosserial_add_client_target(time_tf time_tf.axf ALL) #rosserial_add_client_target(time_tf flash) #rosserial_add_client_target(time_tf size)

Array test tutorial


DIRECTORY array_test


#) #rosserial_add_client_target(array_test array_test.axf ALL) #rosserial_add_client_target(array_test flash)

freeRTOS for tm4c123gxl

rosserial_configure_client( DIRECTORY freertos123 TOOLCHAIN_FILE ${ROSSERIAL_TIVAC_TOOLCHAIN} ) rosserial_add_client_target(freertos123 freertos123.axf ALL) rosserial_add_client_target(freertos123 flash) rosserial_add_client_target(freertos123 size) rosserial_add_client_target(freertos123 dump)

Originally posted by Kenjr on ROS Answers with karma: 1 on 2017-03-19

Post score: 0

Original comments

Comment by gvdhoorn on 2017-03-20:
This could point to a problem with a missing add_dependencies(..) in the CMakeLists.txt of rosserial_tivac_tutorials. If you could include a link (or better yet: copy the contents into your question) we could take a look.


1 Answer 1


Rosanswers logo

There should be no issue with your kinectic distro.

This is an issue with the cmake target *_roslib, and the fact that messages are defined in the same catkin package as the rosserial targets. At build time, if target _roslib doesn't find the messages in $PYTHON_PATH, it won't generate them for rosserial targets.

Please try the following procedure:

rm devel build -fr
catkin_make rosserial_tivac_tutorials_generate_messages
source devel/setup.bash

Originally posted by vmatos with karma: 124 on 2017-03-20

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by Kenjr on 2017-03-21:
xxx@home-pc:~/Tiva $ export | grep PYTHON declare -x PYTHONPATH="/home/xxx/Tiva/devel/lib/python2.7/dist-packages:/opt/ros/kinetic/lib/python2.7/dist-packages" p

Comment by Kenjr on 2017-03-21:
Tried the procedure you recommended and I get the same results.

Comment by vmatos on 2017-03-21:
Did you delete build and devel folders before trying the procedure?

Comment by Kenjr on 2017-03-21:
No I didn't. Got a completely different result, appears to have worked OK. Should I copy the results to the "Your Answer".

Comment by tfoote on 2017-03-21:
@Kenjr, please edit your question to add more information. Also please use the preformatted text layout for your code and console snippets (101010) button to make things more readable.

Comment by Kenjr on 2017-03-22:
Thanks I see the 101010 icon.

Comment by Kenjr on 2017-03-22:
Problem solved I was successful after deleteing the build and devel folders and running the procedure suggested by vmatos.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.