0
$\begingroup$

Rosanswers logo

(Moved from here on behalf of @shzargar)

I want to use set_max_acceleration_scaling_factor (newly added method to moveit_commander) in my python program to control the velocity but I get:

  File "./nextage_moveit_waypoint.py", line 117, in main
    larm.set_max_velocity_scaling_factor(0.5)   
AttributeError: 'MoveGroupCommander' object has no attribute 'set_max_velocity_scaling_factor'

running this : rosversion moveit_commander gives me this: 0.6.1

I tried to do update with sudo apt-get install ros-indigo-moveit-full-pr2 (or sudo apt-get install ros-indigo-moveit) source /opt/ros/indigo/setup.bash

but at the end, rosversion moveit_commander returns me the same version.

How I can update my moveit_commander and make sure that I have set_max_acceleration_scaling_factor


Originally posted by 130s on ROS Answers with karma: 10937 on 2017-03-14

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

moveit_commander for ROS Indigo at the time of writing is version 0.7.8 (changelog), but its binary is not yet available to general public and only available on so-called "shadow" repository (testing repo before the public release). You can apply the setting in the link and update.

Note that in order to update an already-installed Ubuntu package you may want to run apt-get with --reinstall option, e.g.:

    sudo apt-get install --reinstall ros-indigo-moveit-commander

Originally posted by 130s with karma: 10937 on 2017-03-14

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.