0
$\begingroup$

Rosanswers logo

I am creating a GUI for a robot using rqt_gui, both connected together by the same WIFI network.

The plugins in my rqt_gui are 1) RVIZ, 2) Image_view and 3)dynamic_reconfigure.

Whenever i run the rqt_gui, and access RVIZ , the whole rqt_gui freezes and turns black shortly. Thus i am unable to do anything with it.

RVIZ - For LIDAR map and navigation through it

Image_view - To have live camera feed from the robot

rqt_dynamic_reconfigure - to change the parameters of the robot from the laptop

Can someone please tell me why am i facing the problem and is there any solution to the problem!

My laptop is Lenovo ideapad 700 running in Ubuntu 14.04 and ROS Indigo.

Please let me know if there is need for any other info.

Any form of help would be apprciated!


Originally posted by Azhar on ROS Answers with karma: 100 on 2017-03-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Not really an answer, but you may want to separately open rqt windows to receive high amount of data.

In your particular case, both rqt_rviz with laser output and rqt_image_view with camera images can be receiving very high amount of data and thus take up computer resource. Note that rqt_rviz wiki page states it's experimental and using the standalone RViz is recommended.


Originally posted by 130s with karma: 10937 on 2017-03-08

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Azhar on 2017-03-09:
Thank you for your response! :) Will try to do it!

I wanted to create a GUI with everything on one screen. I was just thinking what could be the reason, and how to improve it.

Any idea of how to handle high amount of data so that it will flow with low latency?

Comment by Azhar on 2017-03-13:
Hi, I tried it, RVIZ standalone and it still freezes! :(

Can anyone give me a heads up of what to check? Network? laptop configuration?

Comment by Azhar on 2017-03-22:
it froze again when i open image_view in rqt too. However, when i open both the map and image(theora) from Rviz it works fine. :)

Do take note that i am using to view all this from a slave machine.

Currently, when i try to visualize the Laserscans in RVIZ alone, it freezes. Debugging in progess!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.