0
$\begingroup$

Rosanswers logo

I am trying the run robot_localization's ekf node with amcl and odometry as the inputs. I would like the ekf node to perform a transform from map->odom. Right now both amcl and the ekf node are performing the map->odom transform and this is causing the robot, in simulation, to shake: jumping back and forth between the two estimates. Is there a way to block amcl from publishing the tf transform while still providing information to the ekf node?

I have tried remapping tf to a different name but this also blocks the /amcl_pose topic which is needed for the ekf node.


Originally posted by Nicholash Bedi on ROS Answers with karma: 68 on 2017-02-27

Post score: 0


Original comments

Comment by Julio Aguilar on 2017-03-08:
Hi there,

were you able to start a robot_localization's ekf node with amcl and odometry? I haven't been able to. My ekf instance doesn't publish the right transform. It filters the odom frame even though I specified world_frame as map_frame. Did you do something else besides blocking the amcl tf?

Comment by Nicholash Bedi on 2017-03-08:
Hi, You also need to make sure map_frame, odom_frame, and base_link_frame are set appropriately. Additionally, publish_tf should be set to true. What do you mean by "filters odom"? Do you have a direct map to base_link transform? or no Map or odom frame at all?

Comment by Julio Aguilar on 2017-03-08:
Hi, could you look at http://answers.ros.org/question/256504/yet-another-problem-with-robot_localization-and-amcl/ ?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Nicholash,

you just need to change the parameter 'tf_broadcast' to false in your config file of the amcl filter. That should stop the filter from broadcasting the map->odom transfrom.


Originally posted by Julio Aguilar with karma: 56 on 2017-03-03

This answer was ACCEPTED on the original site

Post score: 3

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.