0
$\begingroup$

Rosanswers logo

My Gazebo is not publishing the clock anymore. I don't know what I did wrong. A few days ago it worked, but not anymore.

"use_sim_time" is set to true (rosparam get use_sim_time returns true) The time in the simulator is running.

I used the sasc version of Gazebo (Gazebo 8.0), but reverting to 7.5 doesn't change it.

Between the last time it worked and the first time I noticed it doesn't work anymore, I installed CUDA 8 and compiled OpenCV 3.1 from source. But I also reverted back to CUDA 7.5 and the default opencv of my system which doesn't make it work.

It seems to me that on no other topics something is published either. But if I manually publish something (i.e. rostopic pub /test std_msgs/String "test" -r 5) I can display the content via rostopic echo.

Any clues of what might be wrong?


Originally posted by WLemkens on ROS Answers with karma: 33 on 2017-02-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If nothing is publishing, check firewalls and whether you have a ROS_IP, ROS_HOSTNAME or ROS_MASTER_URI setting in your .bashrc that points to wrong IP addresses.


Originally posted by gvdhoorn with karma: 86574 on 2017-02-27

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by WLemkens on 2017-02-27:
Yes thank you! It was pointing to 127.0.0.1 instead of my real ip-address.

Comment by gvdhoorn on 2017-02-27:
What was pointing to 127.0.0.1? In any case, that should probably also work.

Comment by WLemkens on 2017-02-27:
ROS_IP and ROS_MASTER_URI were pointing to 127.0.0.1. After changing it to use the ip of my network card the messages were working again.

Comment by gvdhoorn on 2017-02-27:
If you are not trying to distribute your ROS application across multiple networked hosts, the setting all of those is probably not necessary. Not setting them will allow ROS to detect proper values for them automatically.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.