0
$\begingroup$

Rosanswers logo

Hello,

I have the following configuration with two machines running on Ubuntu: On one machine I run the ros master, and a listener (tutorial one)

On the other I have a talker (again from the tutorial). I set the ROS_MASTER_URI as specified in http://wiki.ros.org/ROS/Tutorials/MultipleMachines. I am able to ping between the machines, and use netcat to send msgs back and forth from the command lines. I have allowed port 11311 with ufw.

If I run the talker, the listener doesn't get any message. If I run rqt_graph it shows the nodes and the topic on which they publish/subscribe. The listener node's color is in red, and nothing changes if I hover on it.

Any idea for what could be the issue?


Originally posted by highWaters on ROS Answers with karma: 176 on 2017-02-20

Post score: 0


Original comments

Comment by jarvisschultz on 2017-02-20:
It's likely that you don't have your ROS environment variables setup correctly. Please edit your question to describe the exact values for ROS_MASTER_URI, ROS_HOSTNAME, and ROS_IP on both machines.

Comment by dcconner on 2017-02-20:
If you are using HOSTNAME, you need to have consistent /etc/hosts files on both machines

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Disabling ufw completely solved the problem. The weird thing is that, this was working once without the need to disable ufw.


Originally posted by highWaters with karma: 176 on 2017-02-20

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by arminf82 on 2019-09-07:
You can simply allow traffic in your LAN, no need to deactivate ufw completely.

$ sudo ufw allow from 192.168.178.0/24

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.