Rosanswers logo

I am trying to use the velodyne_simulator package to get a VLP-16 working in conjunction with a model of an ev. I cloned the repository a couple of weeks ago and have been working off that which has been working incredibly well.

Yesterday I was trying to make sure I could recreate my workspace so that others could have access to it and was writing a set of instructions for setup which included cloning the repository. When I tried to call catkin_make on my new test workspace I got an error message

CMake Error at /home/hugh/Desktop/alpha/devel/share/gazebo_plugins/cmake/gazebo_pluginsConfig.cmake:141 (message): Project 'velodyne_gazebo_plugins' tried to find library '-lpthread'. The
library is neither a target nor built/installed properly. Did you compile project 'gazebo_plugins'? Did you find_package() it before the subdirectory containing its code is included? Call Stack (most recent call first):
/opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
velodyne_simulator/velodyne_gazebo_plugins/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/hugh/Desktop/alpha/build/CMakeFiles/CMakeOutput.log". See also "/home/hugh/Desktop/alpha/build/CMakeFiles/CMakeError.log". Makefile:7416: recipe for target 'cmake_check_build_system' failed make: *** [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed <

I was wondering if anybody had encountered this problem before and know a solution or can think of something that I have missed which has caused this? I am quite new to ROS and gazebo so I wouldn’t be surprised if I have missed something blindingly obvious.

When I copy over all of the folders in the src directory from my currently working workspace to the new one, catkin_make works properly but when I move just the velodyne_description folder over it still doesn’t work.

Thanks so much!

Originally posted by H_Gottlieb on ROS Answers with karma: 3 on 2017-02-12

Post score: 0


1 Answer 1


Rosanswers logo

There seems to be an issue affecting several gazebo plugin ROS packages:

There is some discussion here:

However, this should only be an issue if you compile gazebo_ros_pkgs from source. It shouldn't be a problem if you install with apt-get:

Originally posted by kmhallen with karma: 1416 on 2017-02-25

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by H_Gottlieb on 2017-02-25:

Sorry I didn't update this post. Still not really sure why there was the problem but my man, kmhallen, is completely right. If you use sudo apt-get to install the binaries then the problem was fixed.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.