0
$\begingroup$

Rosanswers logo

I am currently running a master node on my Jetson TK1(IP - 10.42.0.15) and a remote PC running ubuntu(IP - 10.42.0.1). I have gone through all the setup shown in the setup and multiple machines. Also, I am able to ping into both of them and netcat results are perfect too. I have also gone through ROS answers on setting up the /etc/hosts file. But, when I try to do the rostopic list after a roscore on tegra ,I just dont see anything.

my setup on tegra is:

export ROS_IP=10.42.0.15
export ROS_HOSTNAME=10.42.0.15
export ROS_MASTER_URI=http://10.42.0.15:11311/

Variables setup on PC are:

export ROS_IP=10.42.0.1
export ROS_HOSTNAME=10.42.0.1
export ROS_MASTER_URI=http://10.42.0.15:11311/

Originally posted by kartikmadhira1 on ROS Answers with karma: 121 on 2017-02-11

Post score: 0


Original comments

Comment by epsilonjon on 2017-02-11:
When you run roscore on the master, what is printed to the command line?

Comment by gvdhoorn on 2017-02-11:
This could be roscore binding its socket to the wrong IP, good question @epsilonjon.

Also: @kartikmadhira1: using ROS_IP and ROS_HOSTNAME at the same time is not recommended / necessary. I'd stick to ROS_IP if you are in fact not resolving hostnames.

Comment by kartikmadhira1 on 2017-02-11:
@epsilonjon , The ros master is started with the given IP name and I'm able to run rplidar node too.

Comment by kartikmadhira1 on 2017-02-11:
@gvdhoorn tried with only ROS_IP, but without any help. messages aren't coming.

Comment by epsilonjon on 2017-02-11:
@kartikmadhira1 Are you running rplidar and rostopic list on the master or on the other machine?

Comment by kartikmadhira1 on 2017-02-11:
@epsilonjon rplidar on the master and rostopic list on PC.

Comment by gvdhoorn on 2017-02-12:\

@gvdhoorn tried with only ROS_IP, but without any help. messages aren't coming.

my comment wasn't meant as a "this will solve your problem" kind of comment, but more as a general remark. The semantics of the two variables are different. They shouldn't be used at the same time.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Finally figured it, firewall was at place in the master so did sudo ufw disable to allow port connections and it worked.


Originally posted by kartikmadhira1 with karma: 121 on 2017-02-11

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.