0
$\begingroup$

Rosanswers logo

Dear,

i tried to install UM7 drivers on my RPI with Ubuntu Mate (1.12.1). I installed ros-kinetics library (all). Unfortunatelly, the kinetic package have not um7 library for apt-get. Then i download sources from git ( https://github.com/ros-drivers/um7.git), compile and install it.

Simly, steps:

git clone xxxx

mkdir build

cd build

cmake ../ (sucessfully)

make (sucessfully)

make install (sucessfully)

rosrun um7 um7_driver _port:=/dev/ttyAMA0 : [rospack] Error: package 'um7' not found

Any sugestions where is a problem and how to run UM7?


Originally posted by Wiew on ROS Answers with karma: 53 on 2017-01-14

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

What you did is possible, but I don't recommend it if you just started out.

It's probably easier to create a catkin workspace, put the um7 package in that and build it using catkin_make. If successful, source devel/setup.bash. Then try your rosrun .. command again.

See Creating a workspace for catkin for a tutorial.


Originally posted by gvdhoorn with karma: 86574 on 2017-01-14

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by B Dhruva on 2019-02-13:
Hello.. I am getting error no such file or directory when I do perform rosrun..... command. Followed the same steps as mentioned above.

It would be helpful if I can get pointer to this help

Comment by gvdhoorn on 2019-02-13:
Was the compilation successful? Did you see any errors?

If it was successful: try running rospack profile afer having sourced the devel/setup.bash.

Comment by B Dhruva on 2019-02-13:
Yes compilation was successful. after rospack profile following error. terminate called after throwing an instance of 'std::run time error' what() locale::facet ::_S_create_c_locale name not valid Aborted (core dumped)

it is not able to find package.

Comment by gvdhoorn on 2019-02-13:
Well if rospack throws an error then it wouldn't have run. So effectively the situation hasn't changed.

Comment by B Dhruva on 2019-02-13:
Can you let me know how to debug this? I also tried to install um7 using sudo apt-get install ros-indigo-um7. when I am trying to perform rosrun um7 um7_driver it shows error no file or directory found.

Comment by gvdhoorn on 2019-02-13:
I would guess first make sure the files are actually there, and that um7_driver is actually a binary/ros node.

What is the output of ls -al /opt/ros/indigo/lib/um7?

Comment by B Dhruva on 2019-02-13:
Hello Dhoorn, please find the output below:

administrator@administrator:~$ ls -al /opt/ros/indigo/lib/um7
total 124
drwxr-xr-x  2 root root   4096 Feb 11 05:32 .
drwxr-xr-x 56 root root  12288 Feb 12 07:15 ..
-rwxr-xr-x  1 root root 109720 May 17  2018 um7_driver

Comment by gvdhoorn on 2019-02-13:
Seeing as the node is there and you're running into rospack issues with crashes, I would suggest to post a new question. Please clearly describe what is not working, mention the rospack profile crash, show the ls -al output and refer to this question.

Comment by B Dhruva on 2019-02-13:
#q315560 posted. Thank you :-)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.