0
$\begingroup$

Rosanswers logo

Hi, I am trying to install turtlebot ..on my system containing Ubuntu-16.04 LTS and ROS-Kinetic. I am following instructions from: http://wiki.ros.org/turtlebot/Tutorials/indigo/Turtlebot%20Installation

As mentioned in the webpage the tried the following command for Ubuntu Package Install:

sudo apt-get install ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs

As i am using Ros-kinetic i replaced indigo in the above command line with kinetic. (Is the replacement necessary ?)

The following message is displaced on the command window:

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package ros-kinetic-rocon-remocon

E: Unable to locate package ros-kinetic-rocon-qt-library

E: Unable to locate package ros-kinetic-ar-track-alvar-msgss

Later, i also tried Source Installation.. When i used the command: wstool init src -j5 https://raw.github.com/yujinrobot/yujin_tools/master/rosinstalls/kinetic/kobuki.rosinstall

The following message got diplayed:

Using initial elements from: https://raw.github.com/yujinrobot/yujin_tools/master/rosinstalls/kinetic/kobuki.rosinstall ERROR in config: Unable to download URL [https://raw.github.com/yujinrobot/yujin_tools/master/rosinstalls/kinetic/kobuki.rosinstall]: HTTP Error 404: Not Found

I also tried the same above command with indigo: wstool init src -j5 https://raw.github.com/yujinrobot/yujin_tools/master/rosinstalls/indigo/kobuki.rosinstall The file got downloaded but after using catkin_make It throughed an error:

ins/src/gazebo_ros_kobuki.cpp:8: /usr/include/c++/5/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options. #error This file requires compiler and library support \

How can i used -std=c++11 or -std=gnu++11 in catkin_make command ?


Originally posted by BhanuKiran.Chaluvadi on ROS Answers with karma: 241 on 2017-01-13

Post score: 1


Original comments

Comment by MoGo on 2017-01-25:
I met the almost the same problem. But I use wstool download successfully. After use catkin_make, the -std=c++ 11 error show up. have not figure out yet.

Comment by tfoote on 2018-02-28:
Please ask the compile issue is a separate question with full context and include the full command and console output etc for us to better help you debug.

Comment by chrissunny94 on 2018-02-28:
https://github.com/LillyCorp/junkbot/tree/master/rpv1_install

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

That tutorial is for Indigo but your urls are for kinetic those urls don't exist for kinetic. I don't believe that the code has been changed so likely the indigo urls will work.


Originally posted by tfoote with karma: 58457 on 2018-02-28

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.