0
$\begingroup$

Rosanswers logo

Hello,

I use robot_pose_ekf to fuse odom and imu to get a more accurate tf(from odom to base_footprint),and then let amcl use this tf to provide a tf(from map to base_footprint). And when i see the amcl wiki , it tells me we should use diff-corrected odom model. I also use likelihood_field_problaser model to let amcl not use the scans which hit unexpected obstacles such human beings ,when localizing robot with laser on the global map . In rviz ,when i see amcl provides particle_cloud,it is more converged than old models(diff mode and likelihood_field laser model), very excited and thankful!!!!

  • But sometimes when robot is moving and all particle_cloud is converged( in free map areas ,there is no particle),let us mark this time is t_ktime. Suddenly the particle_cloud is little converged than t_k time ,but it still has some particles converged in robot footprint and in map free areas, there also appears some particles.let mark this time is t_k+1time. This is t_k+1.jpg. when t_k+2time ,robot pose in map jumped very much. It jumped in some should not be place, and the amcl output particle_cloud are all converged in robot footprint, it is weird!!!,This is t_k+2.jpg.
  • when i rosbag record all the topics and rosbag play them , rqt_plot the robot_pose_ekf pose data(i write a node to get robot pose in odom ) and amcl output pose data to watch whether it because robot_pose_ekf data occured . But when i see rivz and rqt_plot,when amcl position jumped ,robot_pose_ekf position data did not jump. I guess this is not odom, imu and robot_pose_ekf' s problem. This is amcl_jumped_data_analysis.png,ans its zoomed out png1,zoomed out png2
  • This is amcl_jump_video.mp4 , amcl_jump.bag , package:to convert_orientation2Yaw_And_get_pose_ekf_position and default.rviz config file
  • when i let amcl node logger level is Debug, i see some print useful information such as "Time jumped forward by [0.364688] for timer of period [0.010000], resetting timer (current=946684907.876552),next _expected=946684907.511864"Dubug infos: Time jumped forward.jpg
  • Does amcl jumped because this message ?? how can i fixed this problem??
  • Any advice will be appreciated and thanks you very very much!!!!

Originally posted by jxl on ROS Answers with karma: 252 on 2017-01-10

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

when amcl's particle_cloud is converged(robot is moving ),next time ,if particle_cloud become the t_k+1.jpg,and next time particles converged to wrong place .This werid phenomenon occured because when amcl take resample ,if the <param name="recovery_alpha_slow" value="0.001"/>and <param name="recovery_alpha_fast" value="0.1"/> (in AMCL.cfg ) , resample will take some random particles and take some particles proportional to latest moment' particles weight .Link is here.So to resolve this ,set the two params all zeros .The reason i will read the probobalistic robotics book.


Originally posted by jxl with karma: 252 on 2017-01-12

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.