0
$\begingroup$

Rosanswers logo

Hello.

I'm installed ros-indigo in Ubuntu 14.04 (VMware). I tried "How to Build a Map Using Logged Data". http://wiki.ros.org/slam_gmapping/Tutorials/MappingFromLoggedData But, I did not play a rosbag file (basic_localization_stage.bag) completely. Generated map was a different map from “basic_localization_stage_ground_truth.png”.

Below is commands and the error message:

$ rosparam set use_sim_time true
$ rosrun gmapping slam_gmapping scan:=base_scan

and, another tarminal;

$ rosbag play ./basic_localization_stage.bag --clock

[ INFO] [1483110424.111356815, 124.700547870]: Laser is mounted upwards.
 -maxUrange 29.99 -maxUrange 29.99 -sigma     0.05 -kernelSize 1 -lstep 0.05 -lobsGain 3 -astep 0.05
 -srr 0.1 -srt 0.2 -str 0.1 -stt 0.2
 -linearUpdate 1 -angularUpdate 0.5 -resampleThreshold 0.5
 -xmin -100 -xmax 100 -ymin -100 -ymax 100 -delta 0.05 -particles 30
[ INFO] [1483110424.158217525, 124.745581898]: Initialization complete
update frame 0
update ld=0 ad=0
Laser Pose= -19.396 -8.33452 -1.67552
m_count 0
Registering First Scan
[ WARN] [1483110424.590366037, 125.179980513]: Detected jump back in time. Clearing TF buffer.

...

[ WARN] [1483110457.960022078, 158.549614954]: Detected jump back in time. Clearing TF buffer.

Others information (generated map, rqt_graph, ...) https://drive.google.com/open?id=1RvMWi9w0ey7r2Gv7k2RUx2tnvPJKj9vW2wef0zPdzgA

I want to solve this problem. Thanks in advance.


Originally posted by ataniguchi on ROS Answers with karma: 16 on 2017-01-10

Post score: 0


Original comments

Comment by ataniguchi on 2017-01-10:
Error messege: [ WARN] [1483110424.590366037, 125.179980513]: Detected jump back in time. Clearing TF buffer.

Comment by ataniguchi on 2017-01-11:
I tried same commands in Ubuntu 12.04 (hydro), but the same problem occurred. I consulted the following pages for the order of commands. http://answers.ros.org/question/217588/error-in-rosbag-play-despite-setting-use_sim_time-param/

I do not know what is wrong.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I probably solved this problem myself. I think that the cause is because the bagfile is wrong.

I got a rosbag file for gmapping from this site.

http://wiki.ros.org/slam_gmapping/Tutorials/MappingFromLoggedData?action=AttachFile&do=view&target=basic_localization_stage.bag

However, This bagfile (basic_localization_stage.bag) might be different from the ground truth map image (basic_localization_stage_ground_truth.png).

Therefore, I got a bagfile with the same name (basic_localization_stage.bag) from others.

http://pr.willowgarage.com/data/gmapping/basic_localization_stage.bag

In this case, gmapping and rosbag worked well. I could get a generated map like a ground truth map.


Originally posted by ataniguchi with karma: 16 on 2017-01-13

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.