0
$\begingroup$

Rosanswers logo

I just keep getting double walls in rtabmap when using it on my robot. I am using a Kinect to map the building. Settings: http://pastebin.com/CDtTe0JV

The result:

image description http://i64.tinypic.com/33vojdz.png

EDIT in response to matlabbe: My odometry source is from the create_autonomy using the roomba 780. I know it has a reasonable drift. The launchfile I am using is RGBD_mapping.launch http://pastebin.com/q6B3S6HD


Originally posted by gijsje170 on ROS Answers with karma: 171 on 2016-12-21

Post score: 0


Original comments

Comment by matlabbe on 2016-12-22:
What is your odometry source? and which launch file are your using (copy/paste stuff related to rtabmap here)?

Comment by gijsje170 on 2016-12-23:
Edited the main question

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi,

if the laser scans are fake laser scans from Kinect, I don't recommend using them for ICP refining (causing more errors as they are not very precise with small FOV). Set --Reg/Strategy 0 --RGBD/NeighborLinkRefining false in rtabmap_args. I see some jumps in odometry. What happens if you disable loop closure detection by adding this --Kp/MaxFeatures -1 to rtabmap_args? The odometry should be smooth, if there are still jumps, there is a problem with odometry. Otherwise it may because of loop closure detection. Try with --Vis/MaxDepth 3.5 to limit the distance of features used for loop closure transformation (features over 4 meters are very noisy with Kinect v1).

EDIT

For loop closure, you can also try increasing --Vis/MinInliers 30 or re-extract features when computing the transformation --RGBD/LoopClosureReextractFeatures true, you may also want to disable --RGBD/ProximityBySpace false to avoid adding constraints with the fake laser scans.

cheers


Originally posted by matlabbe with karma: 6409 on 2017-01-04

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by gijsje170 on 2017-01-05:
I changed the parameters you said and did not really see an improvement. For some reason it saw a loop closure at the wrong time ruining the whole scan. Then I disabled loop closures and actually it worked quite well. Except for the fact that my odometry is really bad.

Comment by gijsje170 on 2017-01-05:
I will improve the odometry of my robot and show you the results / improvements when done.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.