0
$\begingroup$

Rosanswers logo

I run a launch file for irobot-create2 (https://github.com/AutonomyLab/create_autonomy ) then faced issue, I think that is related to python.

My setup:

  • Ubuntu LS12.04
  • Ros Hydro
  • irobot create2

First I run without ca_description/launch/create_2.launch
$ roslaunch ca_driver create_2.launch [desc:=false] [publish_tf:=true]
--> it start communication with irobot.

Next I run launch file ca_description/launch/create_2.launch
--> OSError: [Errno 8] Exec format error

Traceback (most recent call last):
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/__init__.py", line 279, in main
    p.start()
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/parent.py", line 257, in start
    self._start_infrastructure()
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/parent.py", line 206, in _start_infrastructure
    self._load_config()
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/parent.py", line 121, in _load_config
    self.config = roslaunch.config.load_config_default(self.roslaunch_files, self.port, verbose=self.verbose)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/config.py", line 428, in load_config_default
    loader.load(f, config, verbose=verbose)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 698, in load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 670, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 614, in _recurse_load
    self._param_tag(tag, context, ros_config, verbose=verbose)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 95, in call
    return f(*args, **kwds)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 240, in _param_tag
    value = self.param_value(verbose, name, ptype, *vals)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/roslaunch/loader.py", line 466, in param_value
    p = subprocess.Popen(shlex.split(command), stdout=subprocess.PIPE)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error

Originally posted by science00000 on ROS Answers with karma: 20 on 2016-12-07

Post score: 0


Original comments

Comment by mgruhler on 2016-12-08:
This seems like there are problems with access rights or the shebang. crate_2.launch just starts one node, robot_state_publisher and it uses xacro to evaluate the urdf. Is xacro installed? From source? Did you copy something over using a windows PC? Did you change the launchfile?

Comment by science00000 on 2016-12-08:
Hi,
I try to check xacro file
rosrun xacro xacro.py ~/dev/catkin_ws/src/create_autonomy/ca_description/urdf/create_2.urdf.xacro
output err as below :

xacro.XacroException: Some parameters were not set for macro xacro:create_base
**Comment by [science00000](https://answers.ros.org/users/25431/science00000/) on 2016-12-08**:\ In file create_base.urdf.xacro
the parameter wheel_separation not set to specific value
I try set one but have another err
xacro.XacroException: Invalid parameter "wheel_separation" while expanding macro "xacro:create_base" **Comment by [science00000](https://answers.ros.org/users/25431/science00000/) on 2016-12-09**:\ Hi mig I have modified launch file for debug then have error --> OSError: [Errno 8] Exec format error
thanks you :)
$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Maybe it has something to do with macro default parameters added in Indigo (not in Hydro)? I guess xacro would not be happy with this line in particular. You could try removing all the parameters that have a default and just hardcode the values in create_base_gazebo.urdf.xacro.


Originally posted by jacobperron with karma: 1870 on 2016-12-08

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by science00000 on 2016-12-09:
jacobperronYour point is correct :)
I have updated as below

Comment by science00000 on 2016-12-09:\

......
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.