0
$\begingroup$

Rosanswers logo

Hello everybody,

i'm using Ubuntu 14.04 LTS and ROS Indigo

i'm trying to launch tutorial 3 for nav2d package. but it seems that there's error in the mapper.

all what i did is first i launched the toturial3

roslaunch nav2d_tutorials tutorial3.launch

then in a separate terminal i call these services as instructed since i don't have a joystick.

rosservice call /StartMapping 3
rosservice call /StartExploration 2

here is the screen shots of the errors.

image description


here is my rqt_graph

image description


here is my tf view_frames

image description

frames.gv

Thank you in advance.


Originally posted by alhouty808 on ROS Answers with karma: 1 on 2016-12-07

Post score: 0


Original comments

Comment by Sebastian Kasperski on 2016-12-07:
Looks like the mapper dies right on startup. Can you please send the log file that is mentioned in the error message? And please check your installed boost-version. It should be 1.54.0.1 from Ubuntu 14.04. Have you ever installed another boost version then the one from Ubuntu repositories?

Comment by Sebastian Kasperski on 2016-12-07:
PS: Do you have installed nav2d as binary package or is it a source build?

Comment by alhouty808 on 2016-12-07:
as a binary package. here is log file

my boost-version is : 1.54.0.1ubuntu1 i haven't installed another boost version ever.

Thank you for your reply. I really appreciate your time.

Comment by alhouty808 on 2016-12-07:
I hope you didn't forget me here is my log file log file

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Regularly update all your ROS packages to avoid conflicts between packages that have different release versions.


Originally posted by Sebastian Kasperski with karma: 1658 on 2016-12-09

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.