0
$\begingroup$

Rosanswers logo

Dear all,

for the outstep i have to clarify that I'm new to ROS and C++.

I installed my ROS Indigo on UBUNTU 14.04 as it is done in the tutorials. (full-desktop) and afterwards i added the path of the setup.bash to my .bashrc file to source it automatically for each termial startup. I also created my own catkin workspace as shown in the tutorials (catkin_init_workspace, catkin_make and so on) and afterwards i sourced the setup.bash file from my devel folder of the workspace i created. When I echo ROS_PACKAGE_PATH it looks like that:

/home/my_path/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks.

Sometimes I sourced the setup.bash file of my workspace by hand and sometimes (I already tried a lot) I added the command to the .bashrc file. The ROS_PACKAGE_PATH always looks like above.

After playing around with turtlesim and so on I wanted to get a driver for a gps board i have (ublox). So i changed the directory to my workspace via

cd /my_catkin_ws_path/src 

and then cloned the source code (it says it is a catkinized version -- what does this mean?) to it with

git clone https://github.com/KumarRobotics/ublox.git

Then i installed the dependencies of the package with

rosdep install ublox

and finally i built it with

catkin_make

Afterwards i checked the rospack profile and ublox was there. I also checked rospack list and it was there (ublox_gps, ublox_msgs and ublox_serialization).

This was the moment when i thought i can run a ublox node. Should this be the moment? Did i forget anything? Because it just don't works, however i try to. I tried: rosrun ublox_gps ublox_gps_node and some other versions. When i go into the ublox_gps CMakeLists.txt it says "add_executeable(ublox_gps_node src/node.cpp)". Rosrun tells me then that it couldn't find executable named ublox_gps_node below ...ublox/ublox_gps.

At this moment i said to myself, ok let's try another one. I took the book "Learning ROS for Robotics Programming" and tried to install the driver for the first sensor which is used in this book, a joystick, like it is done in the book:

sudo apt-get install ros-indigo-joystick-drivers
rosstack profile & rospack profile

There was no joystick package in any of the profiles. Is this normal?

rosrun joy joy_node

also didn't work! It says: [ERROR] [1476314154.407197494]: Couldn't open joystick /dev/input/js0. Will retry every second.

What am I doing wrong? Can anyone help me?


Originally posted by rotzpippm on ROS Answers with karma: 16 on 2016-10-12

Post score: 0


Original comments

Comment by ahendrix on 2016-10-13:
joystick may not work if you don't have a joystick plugged in. Try running the pre-compiled talker: rosrun roscpp_tutorials talker , because it doesn't have any hardware dependencies.

Comment by rotzpippm on 2016-10-13:
The talker works. Listener also. I did not plug in a joystick, but i plugged in the gps board and it also did't work?

Comment by A_KN on 2016-10-13:
How is the GPS module connected to your computer? Via USB? Check if it is detected using lsusb

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It's running now. I did the following: I installed nmea_navsat_driver package and tried to run it, I did this as told on the wiki ros page for this package:

rosrun nmea_navsat_driver nmea_serial_driver

but it didn't run because I had no permission for dev/ttyUSB0. So after i searched for this error i added my user account to the dialout group. After that I was able to run this driver and i received something (no valid data). Now i went back to the ublox driver and changed in the launch file the port to ttyUSB0 which was by default set to ttyACM0 (or something like this). Then I did the following:

roslaunch /home/the_whole_fu**ing_path/src/ublox/ublox_gps/launch/ublox_gps.launch

and it's running now! I really dont know if this is some kind of proper procedure (maybe somebody knows?) but it's working now!


Originally posted by rotzpippm with karma: 16 on 2016-10-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.