0
$\begingroup$

Rosanswers logo

As stated in Navigation tuning guide http://wiki.ros.org/navigation/Tutorials/Navigation%20Tuning%20Guide#Odometry)?

[The first test checks how reasonable the odometry is for rotation. I open up rviz, set the frame to "odom," display the laser scan the robot provides, set the decay time on that topic high (something like 20 seconds), and perform an in-place rotation. Then, I look at how closely the scans match each other on subsequent rotations. Ideally, the scans will fall right on top of each other, but some rotational drift is expected, so I just make sure that the scans aren't off by more than a degree or two.]

what to do if this test fails? I have an error of 10 degrees when the above test is performed. How to reduce this error so that the scans aren't off by more than a degree or two?

The second test i.e., for translation its working fine. The problem is only when it is rotating.

Someone please help me with this problem. Thanks

I am using Ubuntu 14.04, Ros indigo and it is a differential drive robot.


Originally posted by Dharmateja Kadem on ROS Answers with karma: 190 on 2016-09-25

Post score: 0


Original comments

Comment by spmaniato on 2016-09-25:
I wouldn't say 10 degrees is a complete failure. If your kinematics model was really wrong, you would be seeing massive discrepancies between successive laser scans (90, 180, or even more, degrees). So, double-check your model. Maybe the wheel base is a bit off.

Comment by Dharmateja Kadem on 2016-09-25:
I think wheel base is ok because its working fine when there is a linear motion

Comment by spmaniato on 2016-09-25:
The wheel base (i.e., the distance between the two wheels) does not enter the linear motion calculations, only the angular. Maybe you're confusing it with the wheel radius?

Comment by Dharmateja Kadem on 2016-09-26:
Thanks it worked

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If the problem is only when rotating then, as suggested by @spmaniato, you need to adjust your robot's wheel base (distance between wheels) parameter on your kinematic model.

From what I remember when I had to calibrate my robot's odometry, if your angular error grows clockwise you need to reduce the wheel base parameter. If the angular error grows counterclockwise then increase the parameter (might be the other way round :P)

Good luck!


Originally posted by Martin Peris with karma: 5625 on 2016-09-25

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Dharmateja Kadem on 2016-09-26:
Thanks it worked

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.