0
$\begingroup$

Rosanswers logo

Learning ROS from Mastering ROS for Robotics Programming book from yesterday. Actually i struck up in configuring talker & listener.

Configuration & Errors as follows. I need some help to clear the error.

ROS Indigo Ubuntu 14.04

CATKIN_MAKE:

roos@roos-Inspiron-1520:~$ cd catkin_ws
roos@roos-Inspiron-1520:~/catkin_ws$ catkin_make mastering_ros_demo_pkg
Base path: /home/roos/catkin_ws
Source space: /home/roos/catkin_ws/src
Build space: /home/roos/catkin_ws/build
Devel space: /home/roos/catkin_ws/devel
Install space: /home/roos/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/roos/catkin_ws/build"
####
####
#### Running command: "make mastering_ros_demo_pkg -j2 -l2" in "/home/roos/catkin_ws/build"
####
roos@roos-Inspiron-1520:~/catkin_ws$ roscore
... logging to /home/roos/.ros/log/58f9d6ee-6de2-11e6-aed6-001d09bb3726/roslaunch-roos-Inspiron-1520-17202.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://roos-Inspiron-1520:38168/
ros_comm version 1.11.20

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES

auto-starting new master
process[master]: started with pid [17214]
ROS_MASTER_URI=http://roos-Inspiron-1520:11311/
setting /run_id to 58f9d6ee-6de2-11e6-aed6-001d09bb3726
process[rosout-1]: started with pid [17227]
started core service [/rosout] 

WHILE RUNNING TALKER & LISTENER I AM GETTING FOLLOWING ERROR:

roos@roos-Inspiron-1520:~$ rosrun mastering_ros_demo_pkg demo_topic_publisher
[rospack] Error: package 'mastering_ros_demo_pkg' not found
roos@roos-Inspiron-1520:~$ 
roos@roos-Inspiron-1520:~$ rosrun mastering_ros_demo_pkg demo_topic_subscriber
[rospack] Error: package 'mastering_ros_demo_pkg' not found
roos@roos-Inspiron-1520:~$

Originally posted by Robotfreak on ROS Answers with karma: 1 on 2016-08-29

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Did you add the workspace to your ROS environment?

When you open a new terminal, try this first before running rosrun :

$ source ~/catkin_ws/devel/setup.bash

Originally posted by bhavyadoshi26 with karma: 95 on 2016-08-29

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.