0
$\begingroup$

Rosanswers logo

Hello guys, i'm currently testing some RGBD algorithms, but when i use RGBDSLAM v2 i cant get any input data (Waiting for visual image on topic /xtion/rgb/image_rect_color and waiting for depth image on topic /xtion/depth_registered/hw_registered/image_rect_raw)

On this two topics is data. Rtabmap working without any problem.

Here is my launch file:

<launch>
  <node pkg="rgbdslam" type="rgbdslam" name="rgbdslam" cwd="node" required="true" output="screen"> 
    <!-- Input data settings-->
    <param name="config/topic_image_mono"              value="/xtion/rgb/image_rect_color"/> 
    <param name="config/topic_image_depth"             value="/xtion/depth_registered/hw_registered/image_rect_raw"/>
    <param name="config/topic_points"                  value=""/> <!--if empty, poincloud will be reconstructed from image and depth -->

    <!-- These are the default values of some important parameters -->
    <param name="config/feature_extractor_type"        value="ORB"/><!-- also available: SIFT, SIFTGPU, SURF, SURF128 (extended SURF), ORB. -->
    <param name="config/feature_detector_type"         value="ORB"/><!-- also available: SIFT, SURF, GFTT (good features to track), ORB. -->
    <param name="config/detector_grid_resolution"      value="3"/><!-- detect on a 3x3 grid (to spread ORB keypoints and parallelize SIFT and SURF) -->
    <param name="config/max_keypoints"                 value="600"/><!-- Extract no more than this many keypoints -->
    <param name="config/max_matches"                   value="300"/><!-- Keep the best n matches (important for ORB to set lower than max_keypoints) -->

    <param name="config/min_sampled_candidates"        value="4"/><!-- Frame-to-frame comparisons to random frames (big loop closures) -->
    <param name="config/predecessor_candidates"        value="4"/><!-- Frame-to-frame comparisons to sequential frames-->
    <param name="config/neighbor_candidates"           value="4"/><!-- Frame-to-frame comparisons to graph neighbor frames-->
    <param name="config/ransac_iterations"             value="100"/>
    <param name="config/cloud_creation_skip_step"      value="2"/><!-- subsample the images' pixels (in both, width and height), when creating the cloud (and therefore reduce memory consumption) -->

    
    <param name="config/cloud_display_type"            value="POINTS"/><!-- Show pointclouds as points (as opposed to TRIANGLE_STRIP) -->
    <param name="config/pose_relative_to"              value="largest_loop"/><!-- optimize only a subset of the graph: "largest_loop" = Everything from the earliest matched frame to the current one. Use "first" to optimize the full graph, "inaffected" to optimize only the frames that were matched (not those inbetween for loops) -->
    <param name="config/backend_solver"                value="pcg"/><!-- pcg is faster and good for continuous online optimization, cholmod and csparse are better for offline optimization (without good initial guess)-->
    <param name="config/optimizer_skip_step"           value="1"/><!-- optimize only every n-th frame -->
  </node>
</launch>

Im using Ros Indigo (Ubuntu 14.04) with an asus xtion camera. What i'm doing wrong ? :/

greets tobi


Originally posted by tobi93 on ROS Answers with karma: 21 on 2016-08-15

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Looks about right. When comparing to the default launch file, I see that you are using the hw_registered topic (make sure that there is data on this topic), and you are not starting openni from the same launch file (so I guess you start it externally?).


Originally posted by Felix Endres with karma: 6468 on 2016-08-16

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by tobi93 on 2016-08-18:
Hey, yes I'm starting it externally and on the hw_registered topic is data. Futhermore I have solved the problem. I created a relay from /xtion/rgb/camera_info to /camera/rgb/camera_info.

Comment by Felix Endres on 2016-08-18:
Ah, the camera_info is the culprit. No need to relay, just set the "camera_info_topic" parameter to the correct topic then.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.