0
$\begingroup$

Rosanswers logo

I have left the robot_localization odom_frame parameter with value "odom" and base_link_frame to "base_link" defaults. The tf tree, while running robot_localization and the robot driver ca_driver with publish_tf set to "false". Looks like this (apparently I can't upload a file with less than 5 points): odom floating. base_footprint ---> base_link (broadcaster /ekf_localization) base_link --> right_wheel link (broadcaster /robot_state_publisher) base_link --> left_wheel link (broadcaster /robot_state_publisher) ....

why is ekf_localization broadcasting base_footprint --> base_link ? and leaving odom floating? (not connected to anything) I can't even find base_footprint anywhere in the robot_localization parameter list. It is part of the robot description. Any help clarifying this would be appreciated.

Edit

Adding image of original tf tree image description


Originally posted by ras_cal on ROS Answers with karma: 40 on 2016-08-10

Post score: 0


Original comments

Comment by ahendrix on 2016-08-10:
I've bumped your karma; you should be able to post images now.

Comment by ras_cal on 2016-08-11:
Thank you. I've posted image.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

by changing the base_link_frame parameter value from base_link to base_footprint I was able to connect the odom frame to base_footprint. I can now run the robot and visualize the ekf_localization output in RViz. Interestingly, the base_footprint to base_link transform is now broadcast by /robot_state_publisher


Originally posted by ras_cal with karma: 40 on 2016-08-11

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.