0
$\begingroup$

Rosanswers logo

Hi, i follow read me tutorial of ros_arduino_bridge in this link link text and when i run roslaunch ros_arduino_python arduino.launch, i receive this error:

Connecting to Arduino on port /dev/ttyACM0 ... Traceback (most recent call last): File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/arduino_node.py", line 195, in myArduino = ArduinoROS() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/arduino_node.py", line 87, in init self.controller.connect() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/arduino_driver.py", line 68, in connect test = self.get_baud() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/arduino_driver.py", line 261, in get_baud return int(self.execute('b')); File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/arduino_driver.py", line 178, in execute return int(value) TypeError: int() argument must be a string or a number, not 'NoneType' [INFO] [WallTime: 1468423834.069478] Stopping the robot... [INFO] [WallTime: 1468423834.070452] Shutting down Arduino Node... [arduino-1] process has died [pid 10979, exit code 1, cmd /home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/arduino_node.py __name:=arduino __log:=/home/irisecesi/.ros/log/3ed0dd4c-4904-11e6-9d6d-eca86bf97b81/arduino-1.log]. log file: /home/irisecesi/.ros/log/3ed0dd4c-4904-11e6-9d6d-eca86bf97b81/arduino-1*.log all processes on machine have died, roslaunch will exit shutting down processing monitor... ... shutting down processing monitor complete done

What can i do please?


Originally posted by Emilien on ROS Answers with karma: 167 on 2016-07-13

Post score: 0


Original comments

Comment by Pi Robot on 2016-07-13:
Can you please provide the following additional information: (1) Your version of Ubuntu, (2) Your version of ROS, (3) Which branch of ros_arduino_bridge are you using (e.g. hydro-devel, indigo-devel), (4) which Arduino board are you using (e.g. Uno, Mega, etc.)

Comment by Emilien on 2016-07-14:
I use ubuntu 14.04 , ros indigo, arduino mega and ros_arduino_bridge indigo-devel

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Thanks for the additional info. I have added a try-except around the get_baud() function that should fix this. Please do a "git pull" and see if it works for you. It might also help to increase the timeout parameter in your params file from the default of 0.1 to 0.5. There should be no need to rerun catkin_make.


Originally posted by Pi Robot with karma: 4046 on 2016-07-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.