0
$\begingroup$

Rosanswers logo

I'm running : 1. ROS Indigo 2. Ubuntu 14.04 Trusty

I'm simulating a 6DOF robotic arm using ros_control and using gazebo_ros_control plugins. I'm using Joint Position Controllers.

I have set up the .yaml file containing the type of controllers. I have also added all the transmission and gazebo_ros_control tags in my URDF file.

Everything launches without any error. When I try to publish messages on /robot_arm/joint1_position_controller/command topic I'm unable to move the revolute joints. Interestingly I have two continuous joints among my 6DOF which move.

Also these movements are abrupt and not in a smooth manner. Whereas I've tried tutorials where the arm follows a smoother motion using Joint Position Controllers.

How should I get my revolute joints to move? Please help!


Originally posted by rohin on ROS Answers with karma: 99 on 2016-06-06

Post score: 0


Original comments

Comment by Laurens Verhulst on 2016-06-07:
Are you perhaps using a Jaco or Mico arm? I had the same issue and just changed them to continuous joints.

Comment by rohin on 2016-06-14:
Thanks Laurens! Issue sorted out!

Comment by yin on 2016-09-05:
hello,I also encounter this problem with revolute joints. Is it was the limit seting problem ?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Issue Solved.

Making the joints continuous works.

But the real problem was that the effort and velocity limits of the revolute joints in my URDF description were set to zero.


Originally posted by rohin with karma: 99 on 2016-06-14

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.