0
$\begingroup$

Rosanswers logo

I recently started using RTAB-map (Debian package) under ROS Indigo and Ubuntu 14.04. After doing a short mapping run, I bring up localization mode and view the results in RViz. For the Map display in RViz, I am subscribing to the /rtabmap/grid_map topic and there is an odd semi-circular arc of map cells displayed in the rear half of the plane behind the robot as shown below:

image description

If I rotate the robot, the arc follows the motion. If I change the Map topic to /rtabmap/proj_map, the arc goes away and the map looks normal as shown below:

image description

Any thoughts about what that white arc behind the robot is all about?

Thanks!
patrick


Originally posted by Pi Robot on ROS Answers with karma: 4046 on 2016-06-05

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Patrick,

It seems similar to this issue: https://github.com/introlab/rtabmap_ros/issues/65. This problem affects only /rtabmap/grid_map (which is created from the laser scans).

For now, set map_negative_poses_ignored parameter to true for rtabmap node:

<node pkg="rtabmap_ros" type="rtabmap" name="rtabmap">
    <param name="map_negative_poses_ignored" type="bool" value="true"/>
    (...)
</node>

EDIT In rtabmap_ros 0.11.7-1 (new version just released on Kinetic), you can set flip_scan parameter to fill unknown cells (the arc) in front of the laser rangefinder instead of behind if mounted upside down or if scan values are taken counterclockwise (you don't have to change map_negative_poses_ignored).

<node pkg="rtabmap_ros" type="rtabmap" name="rtabmap">
    <param name="flip_scan" type="bool" value="true"/>
    (...)
</node>

cheers,

Mathieu


Originally posted by matlabbe with karma: 6409 on 2016-06-05

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Pi Robot on 2016-06-05:
Thanks Mathieu. Unfortunately, when I add that parameter, I stop receiving the map altogether on the /rtabmap/grid_map topic. But you're right that I have the laser scanner upside down.

Comment by matlabbe on 2016-06-06:
The parameter map_negative_poses_ignored is affecting the grid_map, cloud_map and proj_map topics the same way. When true, the current sensor data is not added to the map unless the map is updated (when the robot moves). Negative nodes are temporary extra stuff added to maps for convenience.

Comment by Pi Robot on 2016-06-06:
Got it--thanks!

Comment by Pi Robot on 2016-06-12:
Thanks @matlabbe. I'm still using Indigo but will keep the new flip_scan parameter in mind for later.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.