Rosanswers logo


We are trying to visualize in realtime the VLP-16 data in RVIZ.

Our config :

  • Ubuntu 14.04
  • ROS indigo
  • Velodyne VLP-16

We launch in several terminals these following commands :

TTY0 :

$ sudo route add eth0
$ roscore

TTY1 :

$ roslaunch velodyne_pointcloud VLP16-points.launch

TTY2 :

$ rosrun velodyne_pointcloud cloud_node _calibration:=($mypath)/VLP16db.yaml

TTY3 :

$ rosrun rviz rviz -f velodyne

We can see it real time for like a few minutes, and then it freezes.

When we look at the route -n command the velodyne route ( is gone.

After this, if we enter the : sudo route add eth0 command again, rviz shows data correctly in realtime.

Any ideas why the route disappears ?

Thank you in advance for any help you can provide.

Originally posted by ArthurAlear on ROS Answers with karma: 15 on 2016-06-03

Post score: 0

Original comments

Comment by gvdhoorn on 2016-06-03:
Is your machine a DHCP client? Could be that it's flushing the routes upon renewal of the lease. Check syslog or dmesg to see whether the 'loss of route' coincides with lease renewal.

Also: have you checked to see whether the route disappears when you're not running anything from ROS?

Comment by kmhallen on 2016-06-03:
Why are you running two instances of the cloud_node? VLP16-points.launch runs everything (including the cloud_node as a nodelet).



1 Answer 1


Rosanswers logo

  1. @kmhallen is right: don't run the cloud node, because VLP16-points.launch already starts the cloud nodelet. Since they are both publishing the same information to the /velodyne_points topic, the result will be confusing and waste cycles and bandwidth.

  2. The recommended method is to attach the Velodyne to its own ethernet port with a statically assigned IP in the 192.168.1.x range. We normally do it via the Ubuntu network manager like this:

  • IP address:
  • netmask:
  • gateway:

Setting up a VLP-16 is very similar to this 32E tutorial. We'd like to make a VLP-16 version of that tutorial some time soon.

Originally posted by joq with karma: 25443 on 2016-06-03

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by ArthurAlear on 2016-06-20:
Thanks for your answer !


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.