0
$\begingroup$

Rosanswers logo

I've set up ABB RobotStudio according to the ROS wiki tutorial. I'm currently using ROS Indigo on Ubuntu 14.04.4 with RobotStudio 6.03. The virtual controller log says that the Linux PC is connected. When I run

roslaunch abb_irb2400_moveit_config moveit_planning_execution.launch robot_ip:=10.140.60.190

the program runs, and I'm able to see Rviz. On trying basic motion planning, the planning happens successfully, but on executing, my Linux terminal is stuck on this:

[ INFO] [1464764643.403390805]:Received new trajectory execution service request...

At the same time, the virtual controller log displays:

ROS_MotionServer -> Sending 20 points to MOTION task

The robot in RobotStudio doesn't move at all. The initial positions for Rviz as well as RobotStudio are the same. Any idea what's wrong?


Originally posted by karthikj219 on ROS Answers with karma: 11 on 2016-06-01

Post score: 0


Original comments

Comment by gvdhoorn on 2016-06-01:
Things to check: robot is in auto mode?

Comment by karthikj219 on 2016-06-01:
It was in manual, I solved it though. See below.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I solved it on my own. Turns out that making execution_planning_duration=false means you have to remove the allowed_execution_duration_scaling and the allowed_goal_duration_margin. I had to do this because I was initially getting the error

Controller is taking too long to execute trajectory 

So, replacing the goal duration and execution duration scaling parameters did the trick.


Originally posted by karthikj219 with karma: 11 on 2016-06-01

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by gvdhoorn on 2016-06-01:
You shouldn't have to 'remove' those parameters if you correctly disabled the execution monitoring. Did you follow the procedure documented in How do I disable execution_duration_monitoring ? After disabling, the other parameters should be ignored.

Comment by karthikj219 on 2016-06-01:
I used the link you've mentioned above to disable duration monitoring. It didn't directly work, until I commented out the other 2 parameters. Is this a possible bug?

Comment by gvdhoorn on 2016-06-01:
You set the parameter to false in the sub namespace? It's always worked for me that way, so I'd be surprised if this is no longer the case.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.