0
$\begingroup$

Rosanswers logo

hello, i've tried this tutorial but when i rosrun rosserial_python serial_node.py /dev/ttyACM1 or rosrun rosserial_python serial_node.py _port:=/dev/ttyACM1 (my port is ttyACM1), the result is

[INFO] [WallTime: 1464200241.928070] ROS Serial Python Node
[INFO] [WallTime: 1464200241.933151] Connecting to /dev/ttyACM1 at 9600 baud
[ERROR] [WallTime: 1464200259.039163] Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

i'm sure that my rosserial is in indigo and i've tried installed again following this tutorial. the result still the same. though, i remember, a few weeks before, i've tried rosserial with HelloWorld and it was successful. so i really wonder why right know i got this kind of error '-' Help Please!!

anyway, i'm using Ubuntu 14.04.1 with ROS Indigo


Originally posted by adelleodel on ROS Answers with karma: 76 on 2016-05-25

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hey, please check your baud rate. The default baud rate in the tutorial you mentioned above is 57600. This should be set as default when you start serial_node.py, otherwise specify it during startup:

rosrun rosserial_python serial_node.py _baud:=57600 _port:=/dev/ttyACM0

Originally posted by Tones with karma: 635 on 2016-06-23

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Archana Kanwar on 2017-03-28:
Hi, I am also facing the same problem but could not fix it even after setting the baud rate. I am working with razor 9dof IMU and was not able to make communication between Arduino and IMU. Can you please help me out in resolving this problem.

Comment by أسامة الادريسي on 2017-11-04:
I have the same problem with MPU6050, can someone help me??

Comment by rupendra on 2018-12-07:
@Archana . Did u able to solve the error for Arduino and IMU???If yes please tell the solution...Thanks

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.