0
$\begingroup$

Rosanswers logo

Hello,
I want to apply navigation with a Youbot in simulation. I used the simulator provided by ROS and I launch it with the following command:
roslaunch youbot_gazebo_robot youbot.launch

But when I try to move the robot after doing the following indications to bring up the navigation stack: http://wiki.ros.org/youbot_navigation , the robot doesn't move. I have some errors with the hokuyo_node.

I found that the youbot_oodl package provided here: https://github.com/youbot/youbot-ros-pkg/tree/master/youbot_drivers/youbot_oodl is not functional (the OODL include files are missing).

If someone can help me, I will be grateful,

lfr


Originally posted by lfr on ROS Answers with karma: 201 on 2016-05-18

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

A collaborator and I had gotten that working a few months ago, but not using the official youbot_navigation that you mentioned. Instead, take a look at this: https://github.com/pschillinger/youbot_integration it might help (You can safely ignore the "behavior" stuff; it's specific to our project.)


Originally posted by spmaniato with karma: 1788 on 2016-05-19

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by lfr on 2016-05-20:
Thank you, I'll try that

Comment by lfr on 2016-05-20:
I used the launch inside the youbot_navigation package but I have a problem. When I try to move the robot, the arm moves instead of the base. But the problem doesn't come from your package (the same problem appears with my own nodes).

Comment by lfr on 2016-05-20:
It's okay, I found my mistake. I used base_link intead of odom as fixed frame. It works correctly now. Thanks again.

Comment by lfr on 2016-05-23:
Sorry, I have another problem, I cannot see obstacles in the costmap and I don't know why. Can you help me ?

Comment by spmaniato on 2016-05-23:
I'm pretty sure we have not configured the costmaps fully. Take a look at https://github.com/fetchrobotics/fetch_ros/tree/indigo-devel/fetch_navigation and https://github.com/turtlebot/turtlebot_apps/tree/indigo/turtlebot_navigation for examples of how to configure them.

Comment by lfr on 2016-05-23:
Thanks, I found where is the error: I replaced the map_type value which was voxel to costmap and it works.
Thank you again.

Comment by Aff on 2019-02-09:
i can't compile the packages because of an error :invalid new-expression of abstract class type ‘steered_wheel_base_controller::SteeredWheelBaseController’ return new C; have you some tips?

Comment by Aff on 2019-02-10:
i solved that prblem, but now i'm stucked on this: Timed out waiting for transform from base_link to odom to become available before running costmap, tf error: canTransform: target_frame odom does not exist.. canTransform returned after 0.1 timeout was 0.1.

it's my first simulation

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.