0
$\begingroup$

Rosanswers logo

Hi I trying to use some examples with this packages packages getting this warning [ WARN] [1461653020.332402156]: TF2 exception: Lookup would require extrapolation into the future. Requested time 1461653020.318166665 but the latest data is at time 1461653020.303369825, when looking up transform from frame [camera_depth_optical_frame] to frame [camera_rgb_optical_frame], so I checked the rqt_graph and is something rqt_tf_tree

, but I don't known why is this warning and wiht the command roswtf I get :

Found 1 warning(s). Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:

  • /camera/camera_nodelet_manager:
    • /tf_static

Thank you and best regards


Originally posted by soichirutk on ROS Answers with karma: 23 on 2016-04-26

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The warning means that you asked TF for a transform, but the TF listener doesn't have that transform in its buffer yet. In other words, the message you're trying to transform (probably a point cloud, image or depth image) has the time stamp 1461653020.318166665 and has arrived before the corresponding transform. The latest transform that is known to the TF listener has time stamp 1461653020.303369825 (that's 0.01 s earlier).

The solution is to add a waitForTransform before the lookupTransform, as explained in this tutorial.


Originally posted by Martin Günther with karma: 11816 on 2016-04-26

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by soichirutk on 2016-04-26:
Thank you for the answer, but in the node files I use, theres is no transformations, that is why I don't see where I have to add the solution that you propose. Also I don't know if beacuse of this warning the output images in RGB don't appear. It would be better to post an rqt_graph?

Comment by Martin Günther on 2016-04-27:
I couldn't find any tf transformations in the repo you linked either. It would be helpful if you could add more information to your question, such all nodes that you're starting etc.; also, if you run this command in all terminals before starting any nodes, the log output will include...

Comment by Martin Günther on 2016-04-27:
... the name of the node that threw the error: export ROSCONSOLE_FORMAT=[${severity}] [${time}]: ${message} (${node})

Comment by soichirutk on 2016-04-27:
Thank you for your help I'll check what you mentioned, and about what I'm using from the link is the launch file run_kinect_CodeSprint_bis.launch, and it just require the packages object_tracking, HaarDispAda, ground_based_detector, roiViewer. Another fact is that I'm using ROS indigo so

Comment by soichirutk on 2016-04-27:
I had to change the manifest.xml eliminating , and at the CMakeLists.txt added find_package(OpenCV REQUIRED) , *include_directories(${OpenCV_INCLUDE_DIRS})*, target_link_libraries(${PROJECT_NAME} ${OpenCV_LIBRARIES}).

Comment by soichirutk on 2016-04-27:
Hi again, well with ROSCONSOLE_FORMAT the node that is sending this warning is (/camera/camera_nodelet_manager), so it is something about the Kinect

Comment by Martin Günther on 2016-04-28:
Does it also happen if you only do roslaunch openni_launch openni.launch directly?

Comment by soichirutk on 2016-04-28:
No, but if I try this rosrun image_view disparity_view image:=/camera/depth/disparity I get this error QMetaMethod::invoke: Unable to invoke methods with return values in queued connections, something has to be with Opencv I'm working on that issue, thanks for your help..

Comment by soichirutk on 2016-04-28:
Hi I don't have the error about image_view, and also I can see just one window with the rgb image, the Warning still there, but the there is a window that doesn't show anything..

Comment by soichirutk on 2016-04-29:
Hi, the node object_tracking it is like the final step of the process but it just initialize the constructor and approximate_sync_->registerCallback(boost::bind(&ObjectTrackingNode::imageCb, this,_1,_2,_3)); is not working that is why I don't have Image, but I don't know why. Thanks

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.