0
$\begingroup$

Rosanswers logo

Hello,

I have a Mitsubishi Robot Arm assembly in SW and I have tried to export it to URDF but the plugin doesn't work. I have SW 2014 and ROS Jade in Ubuntu 14.04.

My problem is that if I only select a base_link and nothing else, the exporter moves to the joint properties and link properties window and allows me to save the package. But as soon as I add a child to the base_link and try to export, it simply stops working and goes back to the model in SW.

Is there any fixable solution to this problem? If not, is there any update on the exporter compatibility with SW2014?

Thanks for all the help in advance


Originally posted by bhavyadoshi26 on ROS Answers with karma: 95 on 2016-04-25

Post score: 0


Original comments

Comment by gvdhoorn on 2016-04-25:
cross-posted here to ros-sig-solidworks.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Unfortunately, the automatic detection isn't working correctly right now under the latest versions of SolidWorks. Something that I mean to get to. In the meantime, you'll need to insert the reference geometry manually and configure your links to reference the manually inserted reference geometry.

I have been able to get it to work this way with SW 2015


Originally posted by brawner with karma: 581 on 2016-04-25

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by bhavyadoshi26 on 2016-04-25:
Thank you for the swift answer Stephen. I will try to follow the approach you mentioned. Anyhow, should I fail to solve the issue, could you please tell me if you work on the issue?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.