I'm new to robotics and this is my first time building a quadcopter. I'm unable to work out why I keep losing ESCs.

Most recently in testing, I've managed to calibrate all 4 ESCs and accurately control the speed of all 4 motors. But after neatly securing them to the frame, 1 motor didn't work. I recalibrated the ESCs again and, when running them again, the motor still didn't work. However, the other 3 motors continued to run at first, but also suddenly just stopped altogether.

Research suggested that ESCs have a cut-off voltage, indicating that my battery might be too flat, so I immediately looked to recharging it. To my surprise, the (still very new) battery appeared to have bulged out, indicating that it had been damaged.

Further research suggested that the size of the battery I was using is insufficient for the amount of current drawn by the motors. So, without any PWM applied, I reconnected a new fully charged battery in the hope of listening for any beeps to diagnose, and one ESC immediately coughed up a huge puff of smoke.

Before all of this happened, I only managed to get 2 of the ESCs to run their motors. Despite several attempts at tweaking PWM signals and calibrating them, I ended up replacing the other 2.

Unless there's some obvious reason for my ESCs to keep dying on me, I can only assume that these specific ESCs are badly made and I should ask for my money back.

These are the components I'm using:

The Raspberry Pi is powered through its micro USB interface by a 5V Step-Up Voltage Regulator connected to a 5000mAh 3.7V LiPo battery. The PWM Controller is powered to its Vcc pin by the GPIO1 (3.3V) pin from the Raspberry Pi, that also happens to power other sensors.

At the time (when all 4 motors worked), I was able to accurately control them at either 50Hz or 400Hz with 1-2 millisecond duty cycles.

  • $\begingroup$ You didn't say anything about which props you are using. Are you just spinning up the motors without props? $\endgroup$ – Octopus May 25 '15 at 19:56
  • $\begingroup$ Yes, I was running them without any propellers - after learning the hard way, of course. I've subsequently learnt that running them this way at full speed is also bad. Nevertheless, an ESC died when no speed was set (having no PWM generated). $\endgroup$ – Biscuits May 26 '15 at 13:43
  • $\begingroup$ I blew up an ESC when I connected it backwards to the LiPo. Since your problems started after you mounted everything on the frame, are you sure you didn't mess up any wires? Maybe a short somewhere? $\endgroup$ – Mewa May 27 '15 at 16:18

I use those RCtimer ESCs and they have always worked great for me, generally thease (and most) ESCs will be looking for 50Hz pwm with a period between 1-2ms, though generally you will not damage them by altering the pwm output. I would recommended cutting the 5v supply on each ESC as they can act funny and even damage themselves when they are all tied to each other.

Your battery should be fine, I would recommended being careful when using it in a bench setup to monitor it's voltage never letting it drop below 3.0v/cell under load (i.e. 9v) and never below 3.2v unloaded per cell (i.e. 9.6v)

To troubleshoot I would connect the motors one at a time to a known working ESC then connect the ESCs one at a time to a known working motor to see if they work, and then one at a time connect known working ESC motor pairs to be sure they work, then add the pairs one at a time to see if it stops working at a certain number of ESC/motor connections

  • 3
    $\begingroup$ The gens ace 2200mah 11.1v 25c 3s1p lipo battery pack listed in question is rated at Max Continuous Discharge of 55A, which at 11.1 V is 610 W, or only about 150 W per motor. The RCTimer 2208-8 2600kV Outrunner Brushless Motor is rated at Max Power 260 W, so rather than saying “Your battery should be fine” I'd say it's too small to run those motors full out. $\endgroup$ – James Waldby - jwpat7 May 23 '15 at 14:58
  • $\begingroup$ I would agree, however he mentioned it was a test stand setup howeaver if he has props then he definitely needs a bigger/higher C battery $\endgroup$ – Mark Omo May 23 '15 at 15:27
  • $\begingroup$ Thanks for the suggestions, Mark. You mentioned "...cutting the 5v supply on each ESC...". What equipment/component do I need to do this? $\endgroup$ – Biscuits May 24 '15 at 10:04
  • 1
    $\begingroup$ by "...cutting the 5v supply on each ESC..." I am pretty sure you mean the 5V output from the BEC on the ESC. rather than cutting those wires I would recommend using a blade to lift the snap on the connector and pull the wire out including the crimped metal end, then you can reuse it when you need to. cutting it will render it useless until you mend it again. $\endgroup$ – Octopus May 25 '15 at 19:43
  • 1
    $\begingroup$ If the LiPo battery has developed a bulge then it is NOT fine. Do not continue using it. LiPo batteries can catch fire when not used correctly. $\endgroup$ – Octopus May 25 '15 at 19:45

It doesn't seem like those motors are well matched to your battery. They recommend a 2or3 cell LiPo (7.2V or 11.1V) while you are using a 1 cell LiPo (3.6V). I think you'll find most motors will recommend 2 or 3 cells. With only 1 cell you won't likely get enough lift for a multirotor.

Also as a side note, your ESCs should be set to have no cut-off when using it on a multirotor. If your ESCs cut a motor off it will result in a crash, guaranteed. Multirotor ESCs usually disable any sort of cut-off (ie. set the cut-off voltage to 0V).

  • $\begingroup$ Thanks Octopus. I'm, however, not sure why you're saying my battery is not a 11.1V 3-cell LiPo battery when I'm pretty sure it definitely is. $\endgroup$ – Biscuits May 26 '15 at 13:44
  • $\begingroup$ Oh I'm sorry, I read the stat on the battery you use to power the RasPi and understood incorrectly. $\endgroup$ – Octopus May 26 '15 at 18:52

I think it sounds like your motor mounting bolts are too long pressing against or dangerously near the motor windings


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.