0
$\begingroup$

Rosanswers logo

when I print this command

rosrun rviz rviz -d `rospack find hokuyo_node`/hokuyo_test.vcg

in my terminal (Note: My distribution of ROS is hydro and my linux version is 12.04).

This error appear:

$ rosrun rviz rviz -d `rospack find hokuyo_node`/hokuyo_test.vcg
[ INFO] [1460147347.794917828]: rviz version 1.10.20
[ INFO] [1460147347.794991170]: compiled against OGRE version 1.7.4 (Cthugha)
ERROR: the config file '/opt/ros/hydro/share/hokuyo_node/hokuyo_test.vcg' is a .vcg file, which is the old rviz config format.
New config files have a .rviz extension and use YAML formatting.  The format changed
between Fuerte and Groovy.  There is not (yet) an automated conversion program.

I would be grateful if any one help me to solve this problem as soon as possible please send me the correct command

Best Regards


Originally posted by SaraAshry on ROS Answers with karma: 1 on 2016-04-08

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

As the error message says, the rviz config for doing that validation is out of date, and there doesn't appear to be an updated version available.

As an alternative, you can run and set up rviz manually:

  • run rviz with the rviz command
  • set the "Fixed Frame" to "/laser"
  • add a "LaserScan" Display
  • set the topic name to "/scan" in the LaserScan display.

Originally posted by ahendrix with karma: 47576 on 2016-04-08

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by dyupleks on 2016-04-16:
In case, there is no the option "/laser" in Fixed Frame, open a terminal and type this : rosrun tf static_transform_publisher 0.0 0.0 0.0 0.0 0.0 0.0 map laser 100 before you will run rviz

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.