0
$\begingroup$

Rosanswers logo

I'm trying to use a Realsense R200 camera to generate 3-D maps. For this purpose, I have the realsense_r200_nodelet running on $ROS_MASTER_URI like so

roslaunch realsense_camera realsense_r200_nodelet_standalone_manual.launch color_fps:=30 color_height:=480 color_width:=640 depth_fps:=30 depth_height:=480 depth_width:=640

I have rgbdslam running on a separate machine. I run it like so

roslaunch rgbdslam rgbdslam.launch

Unfortunately, I don't see any video being captured on the GUI that comes up. I have updated the rgbdslam.launch file to have the right values for the config parameters. The relevant ones are as shown below

<param name="config/topic_image_mono" value="/camera/color/image_raw"/>
<param name="config/topic_image_depth" value="/camera/depth/image_raw"/>
<param name="config/topic_points" value="/camera/depth/points"/>
<param name="config/base_frame_name" value="/camera_link"/>
<param name="config/camera_info_topic" value="/camera/color/camera_info"/>

I have confirmed using rviz that my machine does receive video stream from the Realsense camera. Does anyone have any pointers on what I might be doing wrong to not receive anything on the rgbdslam GUI.


Originally posted by archit on ROS Answers with karma: 3 on 2016-04-08

Post score: 0


Original comments

Comment by al-dev on 2016-04-08:
Did you check that you are receiving both rgb and depth stream ? Are you sure that your rgb topic is /camera/color/image_raw ? It seems to me that the default was /camera/rgb/image_color.

Comment by archit on 2016-04-09:
Yeah, I'm receiving both the rgb and depth streams (checked with rviz). I changed the topic to /camera/color/image_raw because that it is the one on which Realsense sends the rgb stream (it works when used with rviz).

Comment by al-dev on 2016-04-09:
Ok. Which versions of rgbdslam and of the realsense ROS driver are you using ? I would try setting config/topic_points to "". As specified in the launch file : "if empty, poincloud will be reconstructed from image and depth"

Comment by archit on 2016-04-10:
I'm using rgbdslamv2 (repo) and Intel's package for Realsense (repo). I'm trying what you suggested and it does seem to work. It is just too slow right now.

Comment by al-dev on 2016-04-10:
The performance can be linked to a number of different factors, you might want to create another ticket for it. If this works I will post it as an answer.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Set config/topic_points to "". As specified in the launch file : "if empty, poincloud will be reconstructed from image and depth"


Originally posted by al-dev with karma: 883 on 2016-04-10

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.