0
$\begingroup$

Rosanswers logo

Hello, I am novice in ROS. I am trying to use Kinect 1517 in Turtlebot 2 for map building. I follow the tutorial on http://wiki.ros.org/turtlebot_navigation/Tutorials/indigo/Build%20a%20map%20with%20SLAM. I use source installation of ROS indigo on Ubuntu 14.04 on Asus X200CA Notebook PC (http://wiki.ros.org/turtlebot/Tutorials/indigo/Turtlebot%20Installation). I connect kinect on USB 3.0 port. Here is the step I follow for SLAM;

On turtlebot -- roslaunch turtlebot_bringup minimal.launch then, roslaunch turtlebot_navigation gmapping_demo.launch;

Then, I receive Warning message like tf error, before getting info like starting a 3s RGB and Depth stream flush. Then I receive warning like could not find any compatible depth output mode and camera calibration file not found...

If I open RVIZ on workstation(roslaunch turtlebot_rviz_launchers view_navigation.launch) I get many red sign with status error on RobotModel, Map, global map, local map--these option .

Then I follow this tutorial (http://wiki.ros.org/turtlebot/Tutorials/indigo/3D%20Visualisation) and bringup the turtlebot using

roslaunch turtlebot_bringup 3dsensor.launch

I can see there are message on topic /camera/rgb/image_color in the form of numbers like 185, 178, 175, 179...

But RViz launcher still have red alert sign.

I don't know what happen. Please help...

Here is the detail of gmapping demo launch

process[move_base-18]: started with pid [10076]

[ INFO] [1458666540.053049037]: Initializing nodelet with 4 worker threads.

[ INFO] [1458666541.055557351]: Number devices connected: 1

[ INFO] [1458666541.055649993]: 1. device on bus 000:00 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A22596W01469219A'

[ INFO] [1458666541.058141845]: Searching for device with index = 1

[ WARN] [1458666545.291676562]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: . canTransform returned after 0.101041 timeout was 0.1.

[ WARN] [1458666550.348718294]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: . canTransform returned after 0.101016 timeout was 0.1.

[ INFO] [1458666550.859342411]: Starting a 3s RGB and Depth stream flush.

[ INFO] [1458666550.859545571]: Opened 'Xbox NUI Camera' on bus 0:0 with serial number 'A22596W01469219A'

[ WARN] [1458666551.126985136]: Could not find any compatible depth output mode for 1. Falling back to default depth output mode 1.

[ INFO] [1458666551.156741007]: rgb_frame_id = 'camera_rgb_optical_frame'

[ INFO] [1458666551.156808980]: depth_frame_id = 'camera_depth_optical_frame'

[ WARN] [1458666551.193332146]: Camera calibration file /home/jacques/.ros/camera_info/rgb_A22596W01469219A.yaml not found.

[ WARN] [1458666551.193412833]: Using default parameters for RGB camera calibration.

[ WARN] [1458666551.193462065]: Camera calibration file /home/jacques/.ros/camera_info/depth_A22596W01469219A.yaml not found.

[ WARN] [1458666551.193499649]: Using default parameters for IR camera calibration.

[ INFO] [1458666553.861542704]: Stopping device RGB and Depth stream flush.

[ WARN] [1458666555.052241688]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.gmapping.message_notifier] rosconsole logger to DEBUG for more information.

[ WARN] [1458666555.408494199]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: . canTransform returned after 0.100877 timeout was 0.1.

[ WARN] [1458666560.474323227]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: . canTransform returned after 0.100978 timeout was 0.1.


Originally posted by niraj007 on ROS Answers with karma: 11 on 2016-03-22

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I believe your problem is caused by launching roslaunch turtlebot_navigation gmapping_demo.launch on your workstation, when it should be launched on the Turtlebot laptop instead.

The reason being that gmapping_demo.launch not only starts the gmapping node, but also starts the freenect node for the kinect sensor, and since the kinect sensor is not connected to your workstation the node won't be able to recieve any data from the sensor. If there isn't any data from the sensor then gmapping won't publish any transform information for the map frames.

Try launching these on the turtlebot:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

Then this on the workstation:

roslaunch turtlebot_rviz_launchers view_navigation.launch

in the event that everything works, but the RobotModel still has a red error sign, try closing and reopening RVIZ. Sometimes it doesn't properly reload the RobotModel if you launch it before the model is actually being published (at least for me).

If you still have issues maybe post the terminal outputs from these commands. The Turtlebot launch files should work without any problems, so it must be either which machine you are launching them from, or something to do with your network setup.


Originally posted by Steven_Daniluk with karma: 606 on 2016-03-22

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by niraj007 on 2016-03-23:
Thanks for the solution Stevan_Daniluk. It works perfectly. I have to wait for all the nodes to initiate then only launch the rviz launchers.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.