0
$\begingroup$

Rosanswers logo

Hi all,

I am trying to implement hector slam with rplidar. So far I have no success in launching tutorial.launch in hector slam. I had followed the instructions in this link. Apart from changing the second last line, I have also changed the frame names according to some of the answers in this wiki.

<param name="map_frame" value="map" />
<param name="base_frame" value="base_link" />
<param name="odom_frame" value="base_link" />
<param name="pub_map_odom_transform" value="true"/>
<node pkg="tf" type="static_transform_publisher" name="base_to_laser_broadcaster" args="0 0 0 0 0 0 base_link laser 100"/>

I'll get this error after running the launch file.

{{{[ WARN] [1457932080.622102713]: No transform between frames /map and scanmatcher_frame available after 20.003506 seconds of waiting. This warning only prints once.}}}

I tried viewing the tf tree, the output I get is "No TF data received".

Appreciate any help I can get on this issue as I am new to both linux and ROS. I am running ros jade and linux unbuntu. I haven't edit any other launch file from hector slam. Thanks in advance!


Originally posted by bongkw on ROS Answers with karma: 1 on 2016-03-14

Post score: 0


Original comments

Comment by linfeng on 2016-04-15:
hello,Have you solved this problem? i am facing this problem the same as you.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Sorry for very late answer. Have you set the parameter "pub_map_scanmatch_transform" and also set the parameter "tf_map_scanmatch_transform_frame_name" as scanmatcher_frame. These parameters must be set for hector_mapping node in order to get a transform between map and scanmatcher_frame. Have a look at the details of this parameters at link.


Originally posted by gp with karma: 166 on 2016-06-03

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.