0
$\begingroup$

Rosanswers logo

I'm working through the first tutorial on using MoveIt with CRAM, and I'm able to load the tutorial module, query the state of the robot, etc. without problems.

However, when I try to move the robot with the line

(move-link-pose "r_wrist_roll_link" "right_arm" tuti:*pose-mid*)

the REPL shows

[(MOVEIT) ERROR] 1457223557.388: Empty actionlib response.

and the MoveIt terminal window says

[ERROR] [1457223552.356453336]: Exception thrown when deserializing message of length [5034] from [/tutorial-client]: Buffer Overrun

What might be the problem? I thought that maybe some piece of CRAM code was built against an old version of moveit_msgs, but I've tried catkin_make-ing in a clean workspace with no change.


Originally posted by abestick on ROS Answers with karma: 18 on 2016-03-05

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I just tried out the tutorial and the call succeeded for me.

Which version of cram_moveit and cram_tutorials are you using?

The link to the repository in the tutorial was a bit outdated, so I updated it now (and also cleaned up the code in the repo a bit). If you're using cram_moveit version 0.2.1 (see package.xml), then cloning from the updated link in the tutorial might help.


Originally posted by gaya with karma: 311 on 2016-03-07

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by abestick on 2016-03-07:
I was indeed using 0.2.1, and updating the cram_tutorials package as you suggested fixed it! Thanks!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.