0
$\begingroup$

Rosanswers logo

I have Asus Xtion Pro (1d27/0601) and try to launch openni2.launch (from openni2_launch package). I get the following error:

Unsupported depth video mode - Resolution: 1280x1024@15Hz Format: Depth 1mm

Interestingly, with openni.launch everything works smoothly. WHat could be the problem with openni2? Alternatively, is there an option to tell other packages to work with openni? (for example, 3dsensor.launch from turtlebot_bringup package)


UPDATE: the solution was in restarting everything (including roscore) - pay attention to comment section under the accepted answer.


Originally posted by gavran on ROS Answers with karma: 526 on 2016-03-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

AS fare I know your sensor supports VGA@30fps or QVGA@60fps for the depth image. And even this resolution is not the effective resolution of the sensor.

If you have a bad configuration, e.g. you set a wrong resolution with dynamic reconfiguration, you may restart roscore. Many configuration in ROS are stored in the parameter server and it runs inside of the ROS master. Due to this the configuration persists as long the roscore runs.


Originally posted by MichaelKorn with karma: 1480 on 2016-03-04

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by gavran on 2016-03-04:
I am still confused: why at all does openni2 complain about resolution? I didn't set any specific resolution. Is it reading it from some config file for sensor?

Comment by MichaelKorn on 2016-03-04:
Did you a fresh start of openni2.launch without any arguments? "fresh" means to restart roscore, too.

Comment by gavran on 2016-03-04:
after restarting roscore, suddenly everything works! thanks for the suggestion. do you have any idea what could cause the trouble? Please, add the suggestion of restarting roscore in the answer, and I'll accept so that it can be useful for others as well

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.