0
$\begingroup$

Rosanswers logo

I've modified the turtlesim tutorial to control some servos from a ps3 controller, and everything works fine when everything is running from my laptop. Now I want to move the part/file that actually do the moving of the servos over to a RPi.

I've added

export ROS_MASTER_URI=http://Yoda.local:11311

to the .bashrc on both nodes.

rostopic list/info/type displays the same info on both laptop and RPi, but when I try to get any actual data out, the RPi doesn't receive anything on rostopic echo/hz

I've tried running

rostopic pub -r 10 /robonova3/cmd_vel geometry_msgs/Twist '{linear: {x: 0.1, y: 0.0, z: 0.0}, angular: {x: 0.0,y: 0.0,z: 0.0}}'

on both machines, but its only picked up locally, not by the other machine...

Any suggestions?


Originally posted by Pengatom on ROS Answers with karma: 15 on 2016-02-18

Post score: 0


Original comments

Comment by NEngelhard on 2016-02-18:
Have you also set the ROS_IP on both computers?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This can happen when ROS_IP or ROS_HOSTNAME (only one of the two needed) are not set correctly on both machines. See also lEnvironmentVariables or this Q/A, Searching for "ROS_IP" or "ROS_HOSTNAME" here or on google should also provide sufficient info to fix this issue.


Originally posted by Stefan Kohlbrecher with karma: 24361 on 2016-02-18

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Pengatom on 2016-02-19:
Voila! Thanks Should've been better explained that this is needed. In the tutorial it's only mentioned as something to add if one cannot ssh to the machine - which I could...

Comment by Procópio on 2016-02-25:
you are welcome to edit the wiki to better explain that ;)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.