Rosanswers logo

I'm having trouble viewing a kinect image in RViz. Today, the same rviz config file that has worked in the past did not work. I thought there may be a problem with rviz, so I uninstalled and reinstalled it. That may be part of the problem.


  • ros hydro on ubuntu 12.04
  • rviz version 1.10.20 compiled against OGRE version 1.7.4 (Cthugha)
  • Video card (from lspci): NVIDIA Corporation GK106 [GeForce GTX 645 OEM] (rev a1)
  • using kinect v1 with openni_launch driver

Steps taken:

  1. Click Add, select Image
  2. Set topic to /yellow_kinect/rgb/image_color


  • Image status is "Ok"
  • Number of frames is incrementing normally
  • No image shown -- just black pixels in the image panel

Other things tried:

  • Tried using the Camera display type in my RViz, instead of Image. This does not work either (it's an all-white image).

Sanity checks:

  • rosrun image_view image_view image:=/yellow_kinect/rgb/image_color -- When I do this, I see the live image, not black.
  • I confirmed that RViz and the kinect are both talking to ros master on the same machine (my robot)
  • When I try the same thing from another computer in my lab, the image shows up correctly in RViz.

I think it's an issue with the state of ROS or RViz on my desktop. I was using RViz constantly with the same system setup for weeks. Then I wasn't using it for a few weeks, and now it's broken.

Any suggestions on how to make RViz display the camera images would be greatly appreciated!

Originally posted by dinosaur on ROS Answers with karma: 233 on 2016-02-18

Post score: 0

Original comments

Comment by William on 2016-02-18:
Can you try using a Camera display type? I would expect the image to work. What video card are you using? (note: Hydro is no longer supported so if it is a bug we'll probably not release it into binaries)

Comment by dinosaur on 2016-02-18:
Camera does not work either. All white pixels, no image. Video card (from lspci): NVIDIA Corporation GK106 [GeForce GTX 645 OEM] (rev a1)

Comment by Akif on 2016-02-18:
Is this Kinect v1 (aka Kinect for Xbox 360) or Kinect v2 (Kinect for Xbox One)? Also which library are you using?

Comment by dinosaur on 2016-02-18:
It's Kinect v1 and openni_launch

Comment by donald on 2016-02-19:
Maybe you can have a look at the header of the received images. Is everything "normal" there? (incrementing sequence number, time stamps etc.) I remember having troubles with Rviz due to corrupt header information.


1 Answer 1


Rosanswers logo

Found a solution -- It was to restart my computer!

I think the graphics card was acting up. I noticed an error in the console that was running rviz:

NVIDIA: API mismatch: the NVIDIA kernel module has version 304.125, but this NVIDIA driver component has version 304.131. Please make sure that the kernel module and all NVIDIA driver components have the same version.

I reinstalled the graphics card driver with

$ sudo apt-get install nvidia-304

Then restarted.

I'm not sure which action solved my problem, but rviz is working now.

Originally posted by dinosaur with karma: 233 on 2016-02-21

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.