0
$\begingroup$

Rosanswers logo

The thing is; following screenshot is from simulation, on Gazebo. (And Real robot does this too.) ekf_localization_node uses both of imu and odometry. And using only odometry causes this problem too.

I'm following this guide to tune my robot : ROS Wiki Navigation Tuning Guide I've set Decay Time to 30 and started inplace rotation.

Here is Rviz screenshot: Rviz

Odometry isn't reasonable for rotational motion.

Robot's translational motion is good and reasonable. But the rotational motion is bad for localization. What can I do for correcting odometry data? Or Are there any new issues on ekf_localization?

Thank you.


Originally posted by Orhan on ROS Answers with karma: 856 on 2016-02-08

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

for a real robot, I would say what causes this is a wrong wheel size and wheels distance (assuming a diff drive robot), but as the same happens in simulation, I am not sure about the reason.


Originally posted by Procópio with karma: 4402 on 2016-02-09

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Ok, The problem was wheel_width parameter in the urdf. It was 0.05 and It caused two contacts under wheel: image description

I've set to 0.001 and problem solved, now odometry looks pretty good.


Originally posted by Orhan with karma: 856 on 2016-02-09

This answer was ACCEPTED on the original site

Post score: 4

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.