0
$\begingroup$

Rosanswers logo

Hi, I am trying to get the navigation stack working. I am publishing odometry data, tf data and laser scan to Navigation stack. But I get "Invalid argument passed to canTransform argument source_frame in tf2 frame_ids cannot be empty" error when I initialize Rviz

Navfn ROS topic gives error "For Frame []: Frame [] does not exist". "Transform: [Sender =Unknown Publisher]"I am not able to generate any path to goal for my robot. Any ideas?

I am using Ubuntu 14.04 and ROS Indigo


Edited part: More details Here is the link to the source code: https://github.com/pchatrath/navigation-stack-quadcopter.git I run the run_all script to get all things running. These are the steps that are undertaken: 1.Run roscore

  1. Run houkuyo_node (frame laser)
  2. Run robot_tf_publisher which is a static transform publisher between base_link and laser
  3. Run odometry_publisher code. I have written a subscriber which takes data from /cmd_vel topic and publishes it as output of odometry
  4. Run move_base which configures all the costmap params. The link above has details about all the apramers that I configured.
  5. run rviz

Questions that I have are - can i use odom as the global frame. Have I configured the odometry_publisher subscriber correctly? Thanks

I have edited the code as guided. Path is not generated yet. Link to tf tree pic rviz source frame id error


Originally posted by automate on ROS Answers with karma: 97 on 2016-01-26

Post score: 5

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The issue I guess was I wasn't using a static map for global costmap I had to state: static_map:false and rolling window: true. Now the robot navigates to goal position.


Originally posted by automate with karma: 97 on 2016-02-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.