0
$\begingroup$

Rosanswers logo

I have installed the nav2d from http://wiki.ros.org/nav2d by using: sudo apt-get install ros-indigo-nav2d and then I have to install additional packages, but it dos not work! I use for example: sudo apt-get install stage_ros but get this output:

Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package stage_ros

Can anyone help to how can I install these packages ?


Originally posted by RosUser on ROS Answers with karma: 81 on 2016-01-25

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You should not install dependencies manually. By using "apt-get install" all dependencies should be installed on your system. The correct package name for Stage is ros-indigo-stage-ros.


Originally posted by Sebastian Kasperski with karma: 1658 on 2016-01-25

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by RosUser on 2016-01-26:
From Synaptic Package Manager was p2os_urdf package missing. Now I can run the simulator but it shows the error. ERROR: cannot launch node of type [p2os_urdf/p2os_publisher_3at]: can't locate node [p2os_publisher_3at] in package [p2os_urdf]

Comment by Sebastian Kasperski on 2016-01-26:
p2os_urdf is optional, because it's not released into indigo. You can either get the source code from github, or just uncomment the part from the launch file. (It's only used to show the pioneer-model in RVIZ)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.