0
$\begingroup$

Rosanswers logo

I've been trying to calibrate the Intel RealSense camera using various ROS tools for some time. I'm running Ubuntu 14.04 LTS with ROS Indigo. The nodelet I've been using is: http://wiki.ros.org/RealSense_R200

Has anyone been able to get this camera calibrated within ROS? I'm going to post basically everything I've tried since it might be helpful for others, but this is going to be very long and verbose. Here's what I've tried:

PTAM (http://wiki.ros.org/ethzasl_ptam/Tutorials/camera_calibration). Result: I can launch the camera calibration tool, but the output is distorted and the nodelet crashes shortly after launching. See: PTAM camera calibration output

And the following terminal output:

Welcome to CameraCalibrator 
-------------------------------------- 
Parallel tracking and mapping for Small AR workspaces
Copyright (C) Isis Innovation Limited 2008 
Gui is on
[cameracalibrator-1] process has died [pid 5428, exit code -11, cmd /home/mark/catkin_ws/devel/lib/ptam/cameracalibrator image:=camera/color/image_raw pose:=pose __name:=cameracalibrator __log:=/home/mark/.ros/log/806c7c96-b3ce-11e5-a526-001c42361d26/cameracalibrator-1.log].

log file: /home/mark/.ros/log/806c7c96-b3ce-11e5-a526-001c42361d26/cameracalibrator-1*.log

And the only thing I change in PtamFixParams.yaml was:

ImageSizeX: 640
ImageSizeY: 480

ROS Calibration http://wiki.ros.org/camera_calibration Result: the r200 nodelet doesn't have a /camera/set_camera_info topic, so this method can't launch.

('Waiting for service', '/camera/set_camera_info', '...')
Service not found

libuvc_camera http://wiki.ros.org/libuvc_camera Result: Also fails. Note: I don't launch the R200 nodelet when launching this driver. I think the main problem is that there are multiple video streams coming over one USB. Here's my launch, output, and video4linux information: http://pastebin.com/mD8hvL4u.

What's worth noting is that in the launch, you specify one index, but the device actually has three /dev/videoX entries. I'm not sure how I can map these indices to a global index, but I think if I could I'd be good to go.

And of course, please suggest any other calibration methods; this is just what I've tried so far.

Thanks!


Originally posted by mjedmonds on ROS Answers with karma: 58 on 2016-01-05

Post score: 0


Original comments

Comment by Stefan Kohlbrecher on 2016-01-05:
Note there is a "--no-service-check" option for the ROS camera calibration tool that you can use to skip the wait time for the service. See also http://wiki.ros.org/camera_calibration

Comment by Eigen on 2016-05-29:
I want to calibrate my new Realsense r200, it does not have the servcie set/camera_info. I even checked it with rosservice list and it does not exist for this camera. Which other calibration Tools on ROS have you guys used so far which worked? I am working on ROS Indigo and Ubuntu 14.04 LTS.

Comment by gvdhoorn on 2016-05-29:
@Eigen: please don't post answers to questions if you don't actually want to answer them. Use comments for everything else.

Comment by Eigen on 2016-05-29:
ah ok. sorry

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

--no-service-check resolved the issue with the ROS calibration tool and it works!


Originally posted by mjedmonds with karma: 58 on 2016-01-05

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.