0
$\begingroup$

Rosanswers logo

Hello List,

to get my arm working in moveit, I try to create the ikfast code for a 4DOF with the commands:

rosrun collada_urdf urdf_to_collada my_robot.urdf my_robot.dae
rosrun moveit_ikfast round_collada_numbers.py my_robot.dae my_robot_rounded.dae 5
python `openrave-config --python-dir`/openravepy/_openravepy_/ikfast.py --robot=my_robot_rounded.dae --iktype=translationxaxisangleznorm4d --baselink=1 --eelink=5 --savefile=ikf.cpp

This always fails. First there is a warning:

/usr/local/share/openrave-0.9/plugins/openravepy_configurationcache.so: libconfigurationcache.so: cannot open shared object file: No such file or directory

But this file really exists!

Then at the end there is the following error:

File "/usr/local/lib/python2.7/dist-packages/sympy/matrices/matrices.py", line 2580, in matrix_multiply
raise ShapeError()  
sympy.matrices.matrices.ShapeError

I tried to make the urdf as simple as possible, it only consists of the needed links and joints. The urdf-file can be found at HERE

I tried more complicated urdf's and they work. I use ros-indigo and openrave-0.9 on ubuntu 14.04.

Hopefully someone can help, thanks in advance.

Sietse


Originally posted by Sietse on ROS Answers with karma: 168 on 2015-12-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

When I generate my IKFast plugin for my manipulator, I must to install ROS Hydro for converting the URDF file to Collada, because Indigo didn't work.


Originally posted by Fredylucas with karma: 123 on 2016-02-01

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Sietse on 2016-02-02:
Thanks for this workaround. I'll will try that.

Comment by Chickenman on 2016-02-03:
converting URDF to collada worked for me without any problems. I am running indigo igloo on Ubuntu 14.04 LTS

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.