Rosanswers logo

I'm having trouble with RVIZ being unable to show laser scan point data. I'm not sure if this is an RVIZ problem, a problem in my RVIZ config, or a problem with my setup in general (ie: i'm doing something bad with coordinate frames or something along those lines).

Background: I am new to using tf frames within ROS. I decided to learn how to use tf and frame headers to properly tag all my sensor data so I can use provided packages (like for example hector_mapping). I'm going to try and give background to how I arrived at where I am now in case the context helps because I'm really not sure what I did to break it.

Here's how I used to be able to see my laser scan data (it is from a little neato lidar):

  1. open rviz
  2. add LaserScan
  3. Set topic to neato_scan topic

Next I created a node which transforms my neato_laser frame to base_link, and then configured hector_mapping and launched it. It worked well and I was able to visualize both the map and laser scan data after configuring rivz.

At some point (the problem is I'm not sure exactly what changes I made to trigger, if any) RVIZ stopped showing laser scan data.

Here is what I know:

  • Hector_mapping is still able to see and transform the laser_scan data correctly. The map generates fine and the robot is able to localize from the laser data + map. To me this indicates the coordinate frame transforms are infact setup correctly.
  • I am able to verify there is scan data being generated by doing rostopic echo /neato_scan
  • In RVIZ, no matter what I try, I can't get it to visualize the laser scan data.

I've tried with the full config that allowed me to see the map + laser scan data before, and I've also tried reverting to setting all frames (fixed frame, target frame, etc) to neato_laser and only adding the LaserScan to the visualization.

Present Situation:

  • LaserScan shows status "OK" and under topic it shows xxx messages received which counts up correctly.
  • Occasionally a single point will show up for a split second, usually at the origin. If i place a large decay time, it will show several points, mostly at the origin, and some at impossible locations (for example in mid air directly above the origin)
  • There is no evidence of any errors. All of RVIZ status fields show OK with green check mark.

ITs quite likely I'll need to provide more info/do some debugging to trace this problem but I'm not sure how to proceed. Any help in how to sort this out is much appreciated.

Originally posted by rb on ROS Answers with karma: 130 on 2015-11-27

Post score: 0


1 Answer 1


Rosanswers logo

so I went ahead and restarted the computer for the first time in a couple weeks and the problem resolved itself.

Not only is the point cloud being rendered correctly now, but also things that were missing before that I didn't notice (such as labels on tf transforms) have popped up as well.

Originally posted by rb with karma: 130 on 2015-11-29

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by zkytony on 2016-09-01:
What? You didn't change anything within those weeks?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.